Installation of Jitsi Meet fails

My YunoHost server

Hardware: VPS
YunoHost version:
I have access to my server : Through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I am trying to install the Jitsi Meet application, but during setup I get an error:
link to the full error log

It seems like the error happens when the svcjitsifocus user is being created

DEBUG - + yunohost user create svcjitsifocus -f svcjitsifocus -l svcjitsifocus -m -p ********** -q 0
WARNING - Unknown mail address domain ''

Which should be expected from the code.

Is my server misconfigured, or should the installation script be updated?

Reading the code, it seems that the auth domain does not exist because PACKAGE_CHECK_EXEC is not defined.

Can anyone help me understand what PACKAGE_CHECK_EXEC should do? I can’t find its definition.

Hmmmyeah that variable is set to 1 when this app is being tested by our automatic test suite … It sounds like this app requires additional domains to exist (like auth.domain.tld) so it creates them … But I’m not sure to understand why it does only automatically create them when running the CI and not in other cases.

Pingin @yalh76 who probably knows more about this :stuck_out_tongue:

Ok, I went to the actual documentation and defined the necessary subdomains by hand. It worked and Jitsi is correctly installed now, thanks @Aleks for the reply!

1 Like

I wrote the reasons why the package doesn’t automatically create the sub domains in

It’s more or less linked to the Let’s Encrypt certificate creation limit of 5 per week.

With automatic subdomain and certificate creation, if jitsi installation fails 5 times to follow, you have to wait a week before trying to install it… A bit too annoying…

In addition, current jitsi_ynh is the first version since 5 years, so I didn’t have the necessary retreat to know if the installation would work at 100%

For ending, jitsi is full of java… And java is not life. I had to make some ugly workarounds, like dowloading .deb files, unpacking them and retrieve compiled version.

For really ending, jitsi is made to work with xmpp server prosody… YunoHost include xmpp server metronome (a fork of prosody). And you can’t have both installed. So I had to retrieve prosody lua module to include them in metrnome without knowing how metronome and prosody worked and if the module would work with metronome…

I’m still impressed that it works.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.