Installation de Flarum


#1

Bonjour à tous,

Je viens de tenter une installation de Flarum sur une yunohost à jour et ça coince :

# yunohost log display 20190105-145133-app_install-flarum --share
Info: This log is now available via https://paste.yunohost.org/raw/rifexatawi

La partie qui coince :

# yunohost log display 20190105-145133-app_install-flarum 
description: Install 'flarum' application
log_path: /var/log/yunohost/categories/operation/20190105-145133-app_install-flarum.log
logs: 
(...)
  - 2019-01-05 14:54:33,270: DEBUG - ++ [[ flarum = root ]]
  - 2019-01-05 14:54:33,270: DEBUG - ++ sudo -u flarum COMPOSER_HOME=/var/www/flarum/.composer php -d memory_limit=-1 /var/www/flarum/composer.phar require milescellar/flarum-ext-french -n --ansi -d /var/www/flarum --no-interaction
  - 2019-01-05 14:54:34,473: DEBUG - Using version ^1.2 for milescellar/flarum-ext-french
  - 2019-01-05 14:54:34,474: DEBUG - ./composer.json has been updated
  - 2019-01-05 14:54:34,574: DEBUG - Loading composer repositories with package information
  - 2019-01-05 14:54:34,675: DEBUG - Updating dependencies (including require-dev)
  - 2019-01-05 14:54:40,902: DEBUG - Your requirements could not be resolved to an installable set of packages.
  - 2019-01-05 14:54:40,903: DEBUG - 
  - 2019-01-05 14:54:40,903: DEBUG -   Problem 1
  - 2019-01-05 14:54:40,903: DEBUG -     - milescellar/flarum-ext-french v1.2.1 requires flarum/core ^0.1.0-beta.8 -> satisfiable by flarum/core[0.1.x-dev, v0.1.0-beta.8, v0.1.0-beta.8.1] but these conflict with your requirements or minimum-stability.
  - 2019-01-05 14:54:40,903: DEBUG -     - milescellar/flarum-ext-french v1.2.0 requires flarum/core ^0.1.0-beta.8 -> satisfiable by flarum/core[0.1.x-dev, v0.1.0-beta.8, v0.1.0-beta.8.1] but these conflict with your requirements or minimum-stability.
  - 2019-01-05 14:54:40,903: DEBUG -     - Installation request for milescellar/flarum-ext-french ^1.2 -> satisfiable by milescellar/flarum-ext-french[v1.2.0, v1.2.1].
  - 2019-01-05 14:54:40,903: DEBUG - 
  - 2019-01-05 14:54:41,004: DEBUG - 
  - 2019-01-05 14:54:41,004: DEBUG - Installation failed, reverting ./composer.json to its original content.
  - 2019-01-05 14:54:41,305: DEBUG - + ynh_exit_properly

J’ai l’impression que ça vient de la langue ? Je tente une installation en anglais…
[edit: Ça bloque aussi en anglais…

  - 2019-01-05 15:09:02,341: DEBUG - Using version ^0.3.9 for flagrow/bazaar
  - 2019-01-05 15:09:02,342: DEBUG - ./composer.json has been updated
  - 2019-01-05 15:09:02,442: DEBUG - Loading composer repositories with package information
  - 2019-01-05 15:09:02,542: DEBUG - Updating dependencies (including require-dev)
  - 2019-01-05 15:09:10,285: DEBUG - Your requirements could not be resolved to an installable set of packages.
  - 2019-01-05 15:09:10,286: DEBUG - 
  - 2019-01-05 15:09:10,286: DEBUG -   Problem 1
  - 2019-01-05 15:09:10,286: DEBUG -     - Installation request for flagrow/bazaar ^0.3.9 -> satisfiable by flagrow/bazaar[0.3.9].
  - 2019-01-05 15:09:10,287: DEBUG -     - flagrow/bazaar 0.3.9 requires flarum/core ^0.1.0-beta.8 -> satisfiable by flarum/core[0.1.x-dev, v0.1.0-beta.8, v0.1.0-beta.8.1] but these conflict with your requirements or minimum-stability.
  - 2019-01-05 15:09:10,287: DEBUG - 
  - 2019-01-05 15:09:10,488: DEBUG - 
  - 2019-01-05 15:09:10,488: DEBUG - Installation failed, reverting ./composer.json to its original content.

Cette fois, il râle sur l’extension “Bazaar”…

[edit2: En anglais et sans “Bazaar”, ça passe!