Installation bizarre .... [Errno 52] Invalid url

fr
install

#1

bonjour,
je tente une install depuis ce matin (2 fois) et j’ai toujours cette erreur:

root@raspberrypi:~# yunohost tools postinstall
Main domain: jbalibeux.nohost.me
New administration password: 
Confirm new administration password: 
Error: [Errno 52] Invalid url https://dyndns.yunohost.org/domains (does this site exists ?)
Warning: dyndns_provider_unreachable
Info: Installing YunoHost...
Warning: /bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
Warning: /bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
Info: The configuration file '/etc/nsswitch.conf' is now managed by the service nsswitch.
Success! The configuration has been updated for service 'nsswitch'
Info: The configuration file '/etc/nslcd.conf' is now managed by the service nslcd.
Success! The configuration has been updated for service 'nslcd'
Warning: /bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
Warning: sudo: unable to open /etc/sudoers: Too many open files in system

je finis au bout de 30 min par l’interrompre via ctrl+c
puis retente en vain.
un apt dist-upgrade ne fait pas de mise à jour.
je corrige les locales avec un dpkg-reconfigure locales.
mais ça passe toujours pas.

un reboot me met en mode emergency …
je re-reboot (mode normal) et retente une post install… qui passe…mais:

pour le connecter avec mon nom de domaine (interface admin), je suis obliger de mettre www devant (ou adresse ip)… et là l’interface utilisateur ne passe pas, elle ne prend pas les www, elle!

je comprend pas, c’est quoi ce bordel lol :rofl:

c’etait si simple la derniere fois (ya longtemps)!

ah j’ai oublier: je suis sur raspberrypi3 et c’est donc le derniere version téléchargeable , la 3.1…

edit1:
je viens de remarquer qu’avec chromium ça fonctionne … et sans www !
mais que se passe t il avec firefox? vous savez comment y remedier?

edit2:
ça fonctionne de nouveau grace a cette page: https://yunohost.org/#/certificate_fr
donc résolu? il me semble… mais l’install etait quand même bizarre …

désolé du dérangement, les dev connaissent ce genre de complication à l’installation?


#2

depuis mon install, je reçois ce mail 10 fois par jour!!:

Invalid url https://dyndns.yunohost.org/test/jbalibeux.nohost.me (does this site exists?)
Could not check if jbalibeux.nohost.me is available on dyndns.yunohost.org.

ça ressemble étrangement à l’erreur pendant l’install…

je me souviens, il y a bien longtemp, sur un autre serveur, avoir créér un domaine test.nohost.me ( j’ai donc eu 2 domaine sur le serveur) , mais j’avais fait une demande de suppression.

“test” était-il un sous domaine de mon domaine principal?
et surtout que faire?


#3

Salut,

Si je me trompe pas https://dyndns.yunohost.org/test/ fait partie l’API dyndns.

Pour ce qui est de ton message d’erreur:
jbalibeux.nohost.me et www.jbalibeux.nohost.me retourne la même ip.
Mais le www.jbalibeux.nohost.me revoit un message "La connexion n’est pas sécurisée […] Le certificat n’est valide que pour les noms suivants : yunohost.org, www.yunohost.org, ns.yunohost.org "

Oui … vide le cache de ton firefox ou ouvre une navigation privée. Cela devrait fonctionner


#4

bonjour,
alors, oui le problème de www est résolu (pb certificat)

reste à résoudre ce mail qui arrive 10 fois par jour…

Si je me trompe pas https://dyndns.yunohost.org/test/ fait partie l’API dyndns.

ok mais alors pourquoi ça râle comme ça?