Install script doesn't clean up after error

I took it upon myself to package wallabag-kindle-consumer for YNH.

It’s my first ynh app and this is how far I’ve gotten:

I’ve encountered an issue while trying to run the script in a VM. Namely, the first time I ran the script it encountered an error and quit (which I expected considering this is my first app :wink: ) Here’s the log of that process:

What stomped me was that each time I ran the install script after that, it failed saying that the url I’ve chosen is already taken. It seems that once the script errors on installation for a given url (domain + path), the url stays reserved? This is the log I’m getting on subsequent installs:

If I change the domain and/or the url for the app, the install script goes on further. But I have to change the URL every time I try to install the app. It seems that the url is not released from being locked. How can I clean it up?

Is this perhaps the expected behavior? Should I choose a different path after a failed installation?

Well ugh no it’s not really the expected behavior … it looks like the app is not removed after the failed install … but to investigate this we would need the log of the auto-removal of the app after the failed install

Sure thing — here is the auto-removal log: