Install problem on Miniforums Z83-F pc

Hello Yuno gnomes!
‘Regular computer’ YUNO iso on usb/linux not installing. It’s like usb wasn’t even there. The usb boots good on my other linux computer.
Minisforum Z83-F Mini PC. Checked it was a 64bit good. Should i install other iso or what???


Meh … I guess instead you can try to install a regular debian (be careful to download a Debian 10/Buster ISO, not 11/Bullseye), then install yunohost on top of it using curl | bash

(There’s really not much difference between doing this and using our pre-installed ISO apart from installation time)

Also, how did you copy the installation ISO to the USB? Just to make sure: regular copying of the ISO to a thumbdrive won’t work. Did you follow a guide for that, or have you used bootable ISO’s more often?

Thankyou, well said because i already tried with a debian11 with no success. And i create the usb with regular usb/flash app on my linuxMint which i find more easy than Balena, is that ok? Will try with a Deb10

Only found a Debian mate on Sourceforge there md5 verification code to downnload.
Also found a D-pup but not sure it could be missing some components.

I don’t know which program Linux Mint uses, I guess it should be fine.
To figure out whether the problem is in the USB drive or in the Z83, try this:

  • Put the USB drive in your regular computer/laptop, and let it boot from USB (often F12 can be used to toggle temporary boot device while booting the machine, else check the BIOS)

Does it start the installer? Then the USB is fine, and something is off in the Z83. What are the boot options in BIOS?

  • Perhaps USB is not active as boot option;
  • Perhaps UEFI checks the signature of the boot medium, and it does not accept your non-Windows USB drive. That option should also be in the BIOS.

After the Yuno iso failed i wiped the default Windows of the Z83 machine by a linux_Mint. And it worked. When i attempted to wipe the machine again using Debian11 & then a Debian BunsenLabs it installed very weird, i got this message about proprietary software “Some of your hardware needs non-free firmware files to operate…can be loaded usb brcm/brcmfmac43455-sdio.bin” Somehow Mint has certain elements that make it compatible/passible?
Sorry guys maybe that Z83 is just sh*T. I put money on it thinking it would make a cute Yunohost.

I’m not sure to understand … What does linux mint has to do with this ? What’s “Debian BunsenLabs” ? And where exactly are you seeing that message about proprietary software / brcmfmac43455 ?

Ok, that’s a whole lot of information!

Don’t go looking for a special derivative of Debian. They mostly focus on GUI-elements. Yunohost works best without a GUI, stick with plain Debian.

The hardware (brcm) in this case is the WiFi card. You won’t need it during install (it is connected to your network via wire, is it not?). In case it is needed later on, you still can install it.

Yes, Mint includes non-free drivers and firmware in the installation medium.

It looks like a cute Yunohost. It seems too small to include a second harddisk/SSD for extra storage space, but that might be helped with a USB-harddisk. Adds complexity though!

After Yuno didn’t load I figured trying any other linux os to see if the Z83 could even load anything Linux on it, some machines just don’t. So if Mint os loaded ok then why would Yuno not then work? Well that is all the suspense in my world right now.
By the way Aleks BunsenLabs is one of my favorite Distros, check it out if curious :slight_smile:

Thanks mucho much for that debian10 link.

May that signify the Z83 is lacking certain features i have to patch, i will try the Debbi u linked.
My other mini pc is a Levono and i never had trouble installing anything in the world that says something about Z83, does it not ?

Your positive attitude give me hope. For more memory it has a built-in slot under the lid. One thing though is that it has been criticized about the heating up…

OK debian installed with all disk option but is it normal if i have a ubuntu option on boot-which goes to a ubuntu black screen grub command line ?
I tried to dban disk to delete but not wiping all.

It is not normal to have that line when Ubuntu is not installed. It is normal to go to a black screen after that, if there’s no Ubuntu installed :wink:

Does Debian boot by default, and does it boot normally?

It boots as Debian otherwise the ubuntu grubline must be a leftover from Mint, shows on F7 boot options.
Tried to Dban wipe disk prior, but this rest of ubuntu still there?

I don’t know aboud Dban, and not so much about Ubuntu. If it boots to Debian, I guess you’re fine :slight_smile:

I’d continue with the Yunohost postinstall, if you did not do that yet.

Oh my god, then Debian tells me i don’t have sudoer permissions , bash curl not installed, what’s next…Now i need a Debian class or what or is it just those things.
I was already a so-so user getting along fine with basics on Mint but this might be turning to a ridiculous degree of complexity or what? This is why i was attracted to your product. Nothing simple here. Believe me i am embarased to be so needy as much as you may find anoying. Maybe i should get a fully linux compatible pc.
Have you now also abandoned me also? I’m about to set my desk on fire.
Let meeee tel you about Mehhhh…

During installation, Debian asks to give a root password and to make an initial user. For the user I think there is asked whether you like to give sudo or not. If your user does not have sudo-rights, then it is not set up.

No problem though: you can still ‘su’ instead of ‘sudo’.

openzource@z83: - $ sudo ls
[sudo] password for openzource: 
openzource is not allowed to run sudo on online.  This incident will be reported.
openzource@z83: - $ su -

Pay attention to ’ -’ behind su, else part of the session will be user openzource and part of the session will be root. Putting - behind su switches all to root.

Did you find the installation guide? You can copy the command to install curl there, and then the installation command.

You will get there! :slight_smile:

1 Like

Trying. Maybe because of my order of things.
1-intalled curl
2-curl | bash
3-rembered to install bash
4-re-typed: curl | bash
Trying but result is going this way:


That’s why i’m not a airplane pilot. Oups & thankyou