Install php7.2-zip



I’m trying to use yunohost_php_install experimental helper to properly add php7.2 for Pilea.
But I have some difficulties with php extensions:

When I try to install php7.2-zip I’ve this error:

Les paquets suivants contiennent des dépendances non satisfaites :
 php7.2-zip : Dépend: libzip4 (>= 1.3.2) mais 1.1.2-1.1+b1 devra être installé

You can see what I’m trying to do in test branch of the pilea_ynh repo


That’s unfortunately an expected issue…
As php7.2-zip is available only from a pinned repo, it will be installed as required, but its dependency of libzip4 will be from the standard repo, as this package exist in debian repo.
You could probably find a upper version of this package into the same pinned repo, but apt won’t take anything from it unless it’s clearly asked.

In such a situation, you have to ask explicitly for this package in the version you need.


Unless for this repo, it would be libzip4=1.5.1-4+0~20190318173229.9+stretch~1

I guess it would help to have a helper for that as well…

I tried with:

apt install libzip4=1.5.1-4+0~20190318173229.9+stretch~1

but apt can’t find this version.

So I checked with:

apt-cache policy libzip4

and I got:

  Installé : 1.1.2-1.1+b1
  Candidat : 1.1.2-1.1+b1
 Table de version :
     1.5.1-4+0~20190318173229.9+stretch~1.gbp333132 50
         50 stretch/main amd64 Packages
 *** 1.1.2-1.1+b1 500

So I tried:

apt install libzip4=1.5.1-4+0~20190318173229.9+stretch~1.gbp333132

It seems ok, but will it work on every machine ?

1 Like

An update of this helper is available,
It should solves your problems.

1 Like

Thanks !

I’m gonna check that

Hero, I was stuck on this because my system had two. One was created by pop_os, following your trouble shooting logic help me rectify mine. Cheers.