Install of Yunohost v3.5.2 fails at "Select and Install Software"

My YunoHost server

Hardware: Old computer
YunoHost version: trying fresh install of v3.5.2
I have access to my server : direct access via keyboard
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

I was running Yunohost for over a year on my server. I wanted to reinstall because of some issues I had. Now I can’t get the v3.5.2 ISO to install. During install it keeps failing at “Select and Install Software”.

I tried many different things to troubleshoot this so far:

  • Loaded live USB of Kubuntu to delete and format drive because it had encrypted lvm on it before
  • Tried downloading another copy of the ISO from yunohost.org, checked sig and sha256sum, both OK.
  • Tried using another USB drive (both of these drives have worked in the past when I’ve installed Linux distros and Yunohost)
  • Tried ignoring warnings, skipping ahead to install Grub (server was unstable though, so I need to do a fresh install).
  • After the last fail, in Yunohost installer I tried “Check the CD-ROM(s) Integrity” and it says the “./install.amd/gtk/initrd.gz file has failed the MD5 Checksum verification”.

Is the file on the website corrupt? If it is, this will give newbies a real bad taste for Yunohost.
This is the image I’ve been trying to install for the last 24 hours: https://build.yunohost.org/yunohost-stretch-3.5.2.2-amd64-stable.iso

When I flash the ISO to USB with Etcher or DD it also doesn’t have a ‘label’. I flashed Yunohost before and it had the label Yunohost on there. I flashed a Kubuntu ISO on the USB and it had the correct label.

Had another computer lying around with older install of Yunohost on it. I’m using that now.

For this system, I installed Debian v10 on it no problem. I was going to use curl bash to install Yunohost on it but I know realize that v10 is not supported.

HI

I have the same problem for test on virtualbox try AMD64 Arch and I386

If someone know why ? or have a solution.

Thanks

Herve

Sorry, that’s a known issue being investigated … In the meantime you can install a raw debian (9 !) and install yunohost on top (that’s the same as installing using the ISO basically)

c.f. this page which also provides a link for the Debian 9 ISO : https://yunohost.org/#/install_on_debian

Ah thank you for the clarification.

I thought I was going mad.

I’ll do a Debian 9 install, then Yunohost on top. Thanks!

1 Like