Install nvidia drivers

,

:fr: Bonjour,

Je souhaite installer des drivers NVidia sur mon serveur pour utiliser l’encodage hardware avec mon GPU. Quel serait le meilleur moyen de faire ça ? J’ai trouvé qqs moyens sur internet mais ils demandent de modifier des configurations dont je ne connais pas vraiment les conséquence et préfère demander avant de tout casser.

:uk: Hello,

I want to install NVidia drivers on my server to use the hardware encoding with my GPU. What would be the best way to do this? I found some ways on the internet but they ask to modify configurations which I don’t really know the consequences and prefer to ask before breaking everything.

Mon serveur YunoHost

Matériel: Vieil ordinateur
Version de YunoHost: 4.2.8.3
J’ai accès à mon serveur : En SSH ou Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : pas encore :stuck_out_tongue:

Je me suis impatienté un peu, donc j’ai essayé quelques trucs à base de modifier le fichier /etc/apt/sources.list en ajoutant “non-free” à la ligne

deb http://ftp.debian.org/debian buster main contrib non-free

Derrière je lance un apt update et apt install nvidia-drivers. L’opération d’installation échoue à cause de dépendance qui sont à une version supérieure à celle requise, spécifiquement j’ai identifié libegl1 qui est en version 1.3.2-1~bpo10+2 alors que la dépendance demande une version = 1.1.0-1.

J’ai tenté une installation avec aptitude qui proposait de faire l’installation avec les dépendances existantes, l’installation se déroule normalement, je reboot, j’execute nvidia-smi pour voir si le driver fonctionne mais j’ai une erreur. J’essaie d’installer Cuda, je reboot, je réessaie nvidia-smi, la même erreur.

Je ne sais pas trop quoi essayer à partir de ce moment là…

Perso, pour mes Debian like équipées de GPU NVidia, je vais directement chercher le driver sur le site. J’ai bien moins d’ennuis comme ça qu’en passant via les dépôts (et je ne parle même pas des pilotes libre).

C’est quoi ta config ?

J’ai une Quadro M2000. J’ai oublié de mentionné que j’ai aussi essayé d’utiliser NVIDIA-Linux-x86_64-470.63.01.run que j’ai trouvé sur le site de nvidia mais sans succès, ça foire avec un problème de kernel que je n’ai pas encore eu le temps d’étudier…

Balance ta config et le message d’erreur.

Brotip : utilise inxi -Fxxx si c’est installé, sinon tu peux sortir un uname -a pour avoir le kernel, c’est une commande native.

1 Like

Alors. Pour des raisons que j’ignore j’ai réussi à faire l’installation avec le .run de nvidia. Donc en fait j’ai plus de problème et tout semble fonctionner. Probablement que la fois précédente où j’avais essayé j’avais la mauvaise version des headers ?

En tout cas, je vais laisser ma procédure juste au cas où.

Et effectivement, il est pas mal ce petit utilitaire, merci @Kit :grinning_face_with_smiling_eyes:

$ inxi -Fxxx

System:    Host: domain.com Kernel: 4.19.0-17-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0 Console: tty 0 dm: N/A 
[...]

J’ai executé l’installateur de nvidia :
sudo ./NVIDIA-Linux-x86_64-470.63.01.run
Mon erreur était la suivante :

ERROR: Unable to find the kernel source tree for the currently running kernel.  Please make sure you have installed the kernel     
         source files for your kernel and that they are properly configured; on Red Hat Linux systems, for example, be sure you have 
         the 'kernel-source' or 'kernel-devel' RPM installed.  If you know the correct kernel source files are installed, you may    
         specify the kernel source path with the '--kernel-source-path' command line option.

Je me suis rappelé de la sortie la commande inxi et donc j’ai fait :

sudo apt install linux-headers-4.19.0-17-amd64

(ce que je croyais avoir déjà fait, mais visiblement non, ou alors pas avec la bonne version)

Ensuite j’ai eu tout un tas de warning :

WARNING: nvidia-installer was forced to guess the X library path '/usr/lib' and X module path '/usr/lib/xorg/modules'; these paths
           were not queryable from the system.  If X fails to find the NVIDIA X driver module, please install the `pkg-config`       
           utility and the X.Org SDK/development package for your distribution and reinstall the driver.

puis celui ci :

WARNING: Unable to find a suitable destination to install 32-bit compatibility libraries. Your system may not be set up for 32-bit 
           compatibility. 32-bit compatibility files will not be installed; if you wish to install them, re-run the installation and 
           set a valid directory with the --compat32-libdir option.

et lui :

WARNING: Unable to determine the path to install the libglvnd EGL vendor library config files. Check that you have pkg-config and  
           the libglvnd development libraries installed, or specify a path with --glvnd-egl-config-path.

j’ai répondu oui à ça :

Would you like to run the nvidia-xconfig utility to automatically update your X configuration file so that the NVIDIA X driver
  will be used when you restart X?  Any pre-existing X configuration file will be backed up.

J’ai reboot, et fait un nvidia-smi pour vérifier et c’était bon… Maintenant mon serveur Jellyfin est autrement plus efficace :smiley:
(et au passage pour jellyfin j’ai eu besoin de rien faire de plus que d’installer le driver donc voilà)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.