Impossible d'installer Hotspot sur Raspberry Pi 4B

Mon serveur YunoHost

Matériel: Raspberry Pi 4B à la maison
Version de YunoHost: 4.0.8.2
J’ai accès à mon serveur : Webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

Bonjour à tous,

Je n’arrive pas à installer le Hotspot Wifi. Ci-dessous il y a le log. J’ai pu voir que ce sujet a déjà été traité sur le forum. Le problème avait été réglé en retirant l’antenne wifi ajoutée (le raspberry 4 étant visiblement déjà équipé). La différence avec ma situation c’est que je n’ai pas ajouté d’antenne.
Avez vous une idée du problème ?
Je suis encore novice en la matière et je ne sais pas trop interpréter les erreurs du log.

https://paste.yunohost.org/zukuvirusi.bash

(merci yolateng :wink: )

salut
pas facile de checker ton log sur le forum.
Peux tu “couper” le log de ton post et le copier sur ce pad fournir par l’équipe de Yunohost.


enregistre ce fichier et partage le lien dans ton post réactualisé.

Oui c’est vrai que c’est pas lisible du tout…
C’est bon c’est fait ! Merci !

1 Like

bon visiblement l’ensemble de l installation est complète avec de nouveaux drivers pour la puce wifi lors de celle-ci.
As tu essayé de redémarrer ton raspberry en premier lieu?
Un nouveau kernel est arrivé sur la carte ces jours-ci.

J’ai checké les mises à jour et redémarré mon raspberry. Toujours le même problème…

que donne la commande

systemctl status hostapd.service

la creation d un lien symbolique bug visiblement

Created symlink /etc/systemd/system/multi-user.target.wants/hostapd.service -> /lib/systemd/system/hostapd.service.

Ca me donne :
Unit hostapd.service could not be found
(Je ne suis pas un expert mais je sens que c’est pas normal… :thinking:)

OH une idee à visiter
as tu ete sur Raspi-confi notifier la zone géographique de wifi utiliser sur ton raspi?

https://www.raspberrypi-france.fr/guide/configurer-raspbian
seulement si tu es parti de la derniere version de RaspberrypiOS lite

par la suite je te conseille de taper ces commandes:

sudo systemctl unmask hostapd
sudo systemctl enable hostapd
sudo systemctl start hostapd

Absolument pas ! Je vais essayer de trouver comment faire ça et je reviens aux nouvelles.
Merci !

Il faut passer par raspi-config et sélectionner genre “localization” ou “geographical settings”

Je suis allé dans la config. Je pense avoir correctement changé la zone géographique dans Localization option > WLAN Country. Le serveur a redémarré. Mais toujours pas de hostapd.service…
J’ai aussi mis en français avec la procédure décrite dans le lien que tu donnes yolateng. Et ça me met ce genre de message (au cas où ça peut aider :roll_eyes:) :

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = “en_US.UTF-8”,
LANG = “fr_FR.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to a fallback locale (“fr_FR.UTF-8”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)…
en_GB.UTF-8… done
fr_FR.UTF-8… done
Generation complete.

Est-ce que tu peux faire un journalctl -u hostapd -n 100 --no-pager --no-hostname

Ca me donne ça :

– Logs begin at Sun 2020-11-22 23:09:38 CET, end at Mon 2020-11-23 09:15:11 CET. –
– No entries –

Je précise également (au cas où…) que j’utilise un VPN (celui de Illyse).

J’ai fait quelques avancées dans mon problème. J’ai installé hostapd avec apt install hostapd. J’ai ensuite exécuter les commandes que tu m’as donné yolateng. En fait j’ai suivi le début de la doc suer le site de Raspberry : https://www.raspberrypi.org/documentation/configuration/wireless/access-point-routed.md
Après une installation de l’appli Hotspot puis un redémarrage, ça fonctionne correctement maintenant !

Il reste cependant encore des WARNING dans le log. Je ne sais pas trop si ça révèle un problème (du genre sécurité). J’aimerais avoir votre avis si c’est possible :slight_smile: :
https://paste.yunohost.org/raw/ujopesejah

Merci d’avoir mis sur la piste du hostapd !

Non, si ce n’est que le diagnostique va peut-être râler car il faudrait qu’on intégre un mécanisme pour mieux vérifier l’état du service … mais dans l’absolu ça n’empêche pas les choses de fonctionner

Bonjour,
L’interface wlan0 wifi est par défraut mise en quarantaine.
Vous pouvez le verifier avec la commande :

rfkill list

Pour débloquer :

rfkill unblock all

Puis relancer l’installation de hotspot

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.