Impossible de récupérer la liste d’applications distante community


#1

Hello, after upgrading to version 3.5 I have this error message:

Action

GET /diagnosis
{"locale":"fr"}

Trace

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/moulinette/interfaces/api.py", line 439, in process
  ret = self.actionsmap.process(arguments, timeout=30, route=_route)
   File "/usr/lib/python2.7/dist-packages/moulinette/actionsmap.py", line 523, in process
  return func(**arguments)
  File "/usr/lib/moulinette/yunohost/tools.py", line 740, in tools_diagnosis
  applications = app_list()['apps']
  File "/usr/lib/moulinette/yunohost/app.py", line 255, in app_list
  with open(json_path) as json_list:
IOError: [Errno 2] No such file or directory: u'/var/cache/yunohost/repo/community.json'

I have read the “official” and “community” version has changed so I suppose it’s related to this. Does anyone have the same problem ?


#2

Well uh it shouldn’t be related (we havent changed anything yet in the way the official / community works that affects end-users)

Did you just add the community list recently ?


#3

I already had the community list. I have removed it and added it again yesterday.

2019-04-10 19:29:54,647: SUCCESS - La liste d’applications community a été supprimée

2019-04-10 19:30:08,406: DEBUG - Registering new appslist community at https://app.yunohost.org/community.json
2019-04-10 19:30:08,407: DEBUG - Installing appslist fetch cron job

And nothing more in the logs.


#6

Next step. I could remove the community list using command line. When I try the fetch list command. It fails, for both community and official.

admin@domain:~ $ sudo yunohost app removelist community
Success! The application list community has been removed
admin@domain:~ $ sudo yunohost app fetchlist
Error: Unable to retrieve the remote application list yunohost: HTTPSConnectionPool(host='app.yunohost.org', port=443): Max retries exceeded with url: /official.json (Caused by NewConnectionError('<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x759506d0>: Failed to establish a new connection: [Errno -3] Temporary failure in name resolution',))

#7

So that’s the real issue … DNS resolution seems to be broken on your server for some reason, but that’s unrelated to app list :confused:

Can you check the status of the service dnsmasq (e.g. in ‘Services’ in the webadmin) ?


#8

The service is running but in the logs I can see a lot of

ntpd[597]: error resolving pool 0.debian.pool.ntp.org: Temporary failure in name resolution (-3)

#9

Does cat /etc/resolv.conf shows nameserver 127.0.0.1 ?


#10

Yes, it contains only that. I have tried to add the FDN DNS, but the file is overwritten.


#11

Problem is solved

@Aleks pointed out that my DNS resolution was broken after the last Debian update.

I have not been able to figure out what is wrong. Looks like I’m not good enough in Linux network conf. What I have done is to add the DNS servers in /etc/resolv.conf. Warning: this is a generated file and it is overwritten automatically. Changes have to bee done in /etc/resolv.conf.head (or base, or tail file). There are many paths for this file on various forums. After many tries, this path is the correct one on Rapsbian.

sudo nano /etc/resolv.conf.head  

# Fédération FFDN
nameserver 80.67.169.12
nameserver 80.67.169.40

sudo resolvconf -u
cat /etc/resolv.conf

Note: I’m now using the FFDN federation DNS. They are open and privacy friendly :slight_smile: