Impossible de mettre à jour les paquets

Bonjour,

Mon serveur YunoHost

Matériel: MicroServer HP
Version de YunoHost: 3.8.4.6 (stable)
J’ai accès à mon serveur : En SSH
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

Lorsque j’essaie de mettre à jour les paquets, j’ai le message suivant :
‘Impossible de mettre à jour tous les paquets’

Voici les logs :
args:
apps: null
system: true
ended_at: 2020-10-03 15:53:36.935512
error: “Impossible de mettre \xE0 jour tous les paquets”
operation: tools_upgrade
related_to: []
started_at: 2020-10-03 15:53:30.158894
success: false

============

2020-10-03 17:53:30,182: INFO - Mise à jour des paquets du système (non liés a YunoHost)…
2020-10-03 17:53:30,670: DEBUG - Running apt command :
DEBIAN_FRONTEND=noninteractive APT_LISTCHANGES_FRONTEND=none apt-get --fix-broken --show-upgraded --assume-yes --quiet -o=Dpkg::Use-Pty=0 -o Dpkg::Options::="–force-confold" -o Dpkg::Options::="–force-confmiss" -o Dpkg::Options::="–force-confdef" dist-upgrade
2020-10-03 17:53:30,782: INFO - + Lecture des listes de paquets…
2020-10-03 17:53:30,883: INFO - + Construction de l’arbre des dépendances…
2020-10-03 17:53:30,884: INFO - + Lecture des informations d’état…
2020-10-03 17:53:30,985: INFO - + Calcul de la mise à jour…
2020-10-03 17:53:31,086: INFO - + Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
2020-10-03 17:53:31,086: INFO - + fonts-lyx glances hddtemp javascript-common libblas-common libblas3
2020-10-03 17:53:31,087: INFO - + libgfortran3 libjs-angularjs libjs-jquery libjs-jquery-ui libjs-lodash
2020-10-03 17:53:31,087: INFO - + liblapack3 libsensors4 libwebpdemux2 libwebpmux2 lm-sensors php-net-ldap2
2020-10-03 17:53:31,087: INFO - + php-net-ldap3 python-gnupg python-matplotlib-data python3-bottle
2020-10-03 17:53:31,088: INFO - + python3-cycler python3-dateutil python3-docker python3-matplotlib
2020-10-03 17:53:31,088: INFO - + python3-netifaces python3-numpy python3-pil python3-psutil python3-pyparsing
2020-10-03 17:53:31,088: INFO - + python3-pysnmp4 python3-pystache python3-tz python3-websocket
2020-10-03 17:53:31,089: INFO - + Veuillez utiliser « apt autoremove » pour les supprimer.
2020-10-03 17:53:31,089: INFO - + Les NOUVEAUX paquets suivants seront installés :
2020-10-03 17:53:31,089: INFO - + linux-image-4.9.0-13-amd64
2020-10-03 17:53:31,089: INFO - + Les paquets suivants ont été conservés :
2020-10-03 17:53:31,190: INFO - + moulinette ssowat yunohost yunohost-admin
2020-10-03 17:53:31,191: INFO - + Les paquets suivants seront mis à jour :
2020-10-03 17:53:31,191: INFO - + bind9utils dovecot-core dovecot-imapd dovecot-ldap dovecot-lmtpd
2020-10-03 17:53:31,191: INFO - + dovecot-managesieved dovecot-sieve ghostscript imagemagick imagemagick-6.q16
2020-10-03 17:53:31,191: INFO - + libcups2 libcupsimage2 libcurl3-gnutls libdbi-perl libdns-export162 libgs9
2020-10-03 17:53:31,192: INFO - + libgs9-common libidn2-0 libisc-export160 libisccc140 libluajit-5.1-2
2020-10-03 17:53:31,192: INFO - + libluajit-5.1-common libmagickcore-6.q16-3-extra libmariadbclient18
2020-10-03 17:53:31,192: INFO - + libopenexr22 libssl-doc linux-image-amd64 linux-libc-dev mailman
2020-10-03 17:53:31,192: INFO - + mariadb-server php-pear php7.3 postfix postfix-ldap postfix-pcre
2020-10-03 17:53:31,192: INFO - + postfix-sqlite python-pip python-pip-whl python3-httplib2 python3-pil
2020-10-03 17:53:31,193: INFO - + python3-pip
2020-10-03 17:53:31,694: INFO - + Préconfiguration des paquets…
2020-10-03 17:53:31,695: WARNING -
Extraction des modèles depuis les paquets : 71%
Extraction des modèles depuis les paquets : 100%
2020-10-03 17:53:32,196: INFO - + 41 mis à jour, 1 nouvellement installés, 0 à enlever et 4 non mis à jour.
2020-10-03 17:53:32,197: INFO - + Il est nécessaire de prendre 0 o/72,7 Mo dans les archives.
2020-10-03 17:53:32,197: INFO - + Après cette opération, 195 Mo d’espace disque supplémentaires seront utilisés.
2020-10-03 17:53:32,799: INFO - + (Lecture de la base de données… 63766 fichiers et répertoires déjà installés.)
2020-10-03 17:53:32,799: INFO - + Préparation du dépaquetage de …/mailman_1%3a2.1.23-1+deb9u6_amd64.deb …
2020-10-03 17:53:33,802: WARNING - dpkg: erreur de traitement de l’archive /var/cache/apt/archives/mailman_1%3a2.1.23-1+deb9u6_amd64.deb (–unpack) :
2020-10-03 17:53:33,802: WARNING - le sous-processus nouveau script pre-installation a retourné une erreur de sortie d’état 1
2020-10-03 17:53:34,304: WARNING - Pas de mise à jour nécessaire.
2020-10-03 17:53:35,607: INFO - + Préparation du dépaquetage de …/libisccc140_1%3a9.10.3.dfsg.P4-12.3+deb9u7_amd64.deb …
2020-10-03 17:53:35,908: INFO - + Dépaquetage de libisccc140:amd64 (1:9.10.3.dfsg.P4-12.3+deb9u7) sur (1:9.10.3.dfsg.P4-12.3+deb9u6) …
2020-10-03 17:53:36,509: WARNING - Des erreurs ont été rencontrées pendant l’exécution :
2020-10-03 17:53:36,510: WARNING - /var/cache/apt/archives/mailman_1%3a2.1.23-1+deb9u6_amd64.deb
2020-10-03 17:53:36,711: WARNING - E: Sub-process /usr/bin/dpkg returned an error code (1)
2020-10-03 17:53:36,934: WARNING - Impossible de mettre à jour les paquets suivants : bind9utils, dovecot-core, dovecot-imapd, dovecot-ldap, dovecot-lmtpd, dovecot-managesieved, dovecot-sieve, ghostscript, imagemagick, imagemagick-6.q16, libcups2, libcupsimage2, libcurl3-gnutls, libdbi-perl, libdns-export162, libgs9, libgs9-common, libidn2-0, libisc-export160, libluajit-5.1-2, libluajit-5.1-common, libmagickcore-6.q16-3-extra, libmariadbclient18, libopenexr22, libssl-doc, linux-image-amd64, linux-libc-dev, mailman, mariadb-server, php-pear, php7.3, postfix, postfix-ldap, postfix-pcre, postfix-sqlite, python-pip, python-pip-whl, python3-httplib2, python3-pil, python3-pip

Merci pour votre aide
/Pascal

Bonjour pancho,

Si tu as accès en SSH, est-ce que tu peux essayer de lancer, en tant que root (donc après un sudo -s) la commande suivante :

apt update; apt -uVf install

apt devrait t’afficher plus d’informations sur pourquoi il ne peut pas installer mailman, par exemple des fichiers qui sont en conflit avec un autre paquet.

Shouldn’t it be dist-upgrade instead of install ?

But btw what are these options coming from ? I can find them in the man :[

Bonjour arthurlutz,
J’ai suivi ta recommendation (sudo apt update puis sudo apt -uVf install), puis j’ai relancé la mise à jour des paquets à partir de l’interface d’administration Yunohost.
Tous les paquets ont bien été mis à jour.
Merci
:grinning:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.