Impossible de démarrer le service 'php7.3-fpm'

Bonjour,

Sur un mini server Lime1
yunohost:
repo: stable
version: 4.3.2.2
yunohost-admin:
repo: stable
version: 4.3.2
moulinette:
repo: stable
version: 4.3.2
ssowat:
repo: stable
version: 4.3.2
Je ne parviens pas à démarrer php7.3-fpm depuis le 13/11 à 8h00.

Le message d’erreurs est le suivant :

Impossible de démarrer le service 'php7.3-fpm'
Journaux historisés récents : -- Logs begin at Sun 2021-11-14 00:55:01 UTC, end at Sun 2021-11-14 16:39:02 UTC. -- Nov 14 15:14:40 systemd[1]: Starting The PHP 7.3 FastCGI Process Manager... Nov 14 15:14:41 php-fpm7.3[32661]: [14-Nov-2021 15:14:41] ERROR: [pool hotspot] the chdir path '/var/www/hotspot' does not exist or is not a directory Nov 14 15:14:41 php-fpm7.3[32661]: [14-Nov-2021 15:14:41] ERROR: failed to post process the configuration Nov 14 15:14:41 php-fpm7.3[32661]: [14-Nov-2021 15:14:41] ERROR: FPM initialization failed Nov 14 15:14:41 systemd[1]: php7.3-fpm.service: Main process exited, code=exited, status=78/CONFIG Nov 14 15:14:41 systemd[1]: php7.3-fpm.service: Failed with result 'exit-code'. Nov 14 15:14:41 systemd[1]: Failed to start The PHP 7.3 FastCGI Process Manager. Nov 14 16:39:00 systemd[1]: Starting The PHP 7.3 FastCGI Process Manager... Nov 14 16:39:02 php-fpm7.3[23440]: [14-Nov-2021 16:39:02] ERROR: [pool hotspot] the chdir path '/var/www/hotspot' does not exist or is not a directory Nov 14 16:39:02 php-fpm7.3[23440]: [14-Nov-2021 16:39:02] ERROR: failed to post process the configuration Nov 14 16:39:02 php-fpm7.3[23440]: [14-Nov-2021 16:39:02] ERROR: FPM initialization failed Nov 14 16:39:02 systemd[1]: php7.3-fpm.service: Main process exited, code=exited, status=78/CONFIG Nov 14 16:39:02 systemd[1]: php7.3-fpm.service: Failed with result 'exit-code'. Nov 14 16:39:02 systemd[1]: Failed to start The PHP 7.3 FastCGI Process Manager.

Effectivement, je n’ai pas de /var/www/hotspot.

J’ai désinstallé et réinstallé le hotspot pour voir, il est en route et utilisable, cependant, il n’apparait pas sur le portail du Webadim.

J’ai de plus un message d’erreur sur le webadmin m’indiquant : Erreur de redirection : URL invalide

Je ne sais pas par où commencer pour rétablir la situation.

Merci pour le coup de main !

Oui c’est normal, avec la nouvelle version, la configuration de hotspot se passe directement dans la webadmin de Yunohost

Pas sur de pourquoi ça arrive, mais il faut trouver le fichier de conf php dans /etc/php/7.3/pool.d qui s’appelle sans doute hotspot.conf et le supprimer

Je vais regarder ça tout de suite.
Entre temps, je viens d’essayer un apt update && apt dist-upgrade
Il y avait php7.3-apcu à mettre à jour, sauf que l’erreur ne s’est pas fait attendre :

Failed to start The PHP 7.3 FastCGI Process Manager.
dpkg: error processing package php7.3-fpm (--configure):
 installed php7.3-fpm package post-installation script subprocess returned error exit status 1
Processing triggers for php7.3-cli (7.3.31-2+0~20211022.89+debian10~1.gbp745ac7) ...
Errors were encountered while processing:
 php7.3-fpm
E: Sub-process /usr/bin/dpkg returned an error code (1)
ls -l /etc/php/7.3
total 12
drwxr-xr-x 3 root root 4096 May 23  2020 cli
drwxr-xr-x 4 root root 4096 Oct 26 15:52 fpm
drwxr-xr-x 2 root root 4096 Nov 14 17:21 mods-available

Je ne vois ni pool ni oeufs pour le moment…
:smiley:

Si !
Dans le répertoire fpm !

ls -l /etc/php/7.3/fpm
total 88
drwxr-xr-x 2 root root  4096 Nov 14 17:21 conf.d
-rw-r--r-- 1 root root  5338 May 15  2020 php-fpm.conf
-rw-r--r-- 1 root root 71958 May 15  2020 php.ini
drwxr-xr-x 2 root root  4096 Nov 12 17:04 pool.d

Lequel doit sauter?

/etc/php/7.3/fpm/pool.d/hotspot.conf

(probablement)

Je l’ai renommé mv /etc/php/7.3/fpm/pool.d/hotspot.conf /etc/php/7.3/fpm/pool.d/hotspot.OLD puis relancé apt update && apt dist-upgrade
Le portail Webadmin de Yunohost refonctionne.
Je vais checker plus en profondeur., mais déjà un grand merci @Aleks !

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.