Immich works fine but does not render Video Thumbnails

Hello,

I installed yunohost a few days ago and I can say that I found it really successful as it is easy to use. WordPress, nextcloud etc. with it. I did the installations and it was fine.

The idea of ​​keeping my entire photo/video archive on my own server was very appealing. I read that Immich might be the best Google Photos alternative and installed it. It generally works, but it doesn’t produce video thumbnails, or at least it doesn’t display them. I tried this by entering from several browsers and from the mobile app. Unfortunately, none of them have video thumbnails.

So far I have tried deleting the App several times and doing a clean install. I believe I did not see any error messages during the uninstall and installation phases. Videos and raw photos (such as HEIC) do not create thumbnail. In addition, videos can be watched even if there are no thumbnail, but HEICs are not displayed in any way, even in full screen.

I looked for the reason for this on the immich discord channel, but they wrote that they could not help because it was not a full docker installation.

I didn’t change any settings.
I odted the log file but I can’t upload it, I get an error saying this happened because I’m a new user. I can’t paste it directly here either because I get an error message saying there is longer text than allowed.

Hi,
It seems you didn’t carefully read the message when installing see immich_ynh/doc/PRE_INSTALL.md at master · YunoHost-Apps/immich_ynh · GitHub

HEIC and all video formats work on immich, which I installed with CasaOS, but not on yunohost. Can it be used in this form? Partially yes, but it could be better if it was fixed, that’s why I wanted to report it. Because it is great to manage all subdomains and related applications from one place.

I appreciate your effort.