Iframe NGINX setting [solved]

I want to show an iframe of a yunohost hosted Hubzilla page in my WP blog - but that does not work

DO I have to set somewhere in yunohost

"X-Frame-Options : ALLOWALL"

as option?

Can you help me – in what file I have to do this?

does not seem the right file

thanks for help


Could you kindly give us more details about your installation in order for us to help you (there is a template to fill when you create a topic).


I´m on Yunohost
useing also a cubietruck ARM image https://www.armbian.com/

Problem solved:

I edited in the file ```


the line

more_set_headers "X-Frame-Options : SAMEORIGIN";


more_set_headers "X-Frame-Options : ALLOW-FROM https://sub.yourdomain.tld/"

and did restart nginx

systemctl restart nginx

now the Ifram does work :slight_smile:

edit - August 2020;
things changed in yunohost and nginx so the lines had to be fixt at different files now:


and had to change

more_set_headers "X-Frame-Options : SAMEORIGIN";
# more_set_headers "X-Frame-Options : SAMEORIGIN";

the line
more_set_headers "X-Frame-Options : ALLOW-FROM https://domain.tld";
did not work for me

the line
more_set_headers "X-Frame-Options : DENY";
does work but does not show a iframe :wink:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.