I can't point castopod's config to my s3 storage on linode

Hello to all. I was reading on castopod’s installation documentation the fact I could edit a file to point the storage to my linode’s s3 which I have set up. There is a slight problem. I installed castopod via yunohost and that went well. I have everything the way I want it config wise, except I cannot log in via ssh and cd to /home/yunohost.app/castopod and change the file. I get permission denied errors using both my command prompt and WinSCP. Is there a way to do this as my new user I now HAVE to use when I log in now that yunohost is installed. Just the fact that I installed this app with very little trouble is amazing in and of itself. I want to get in and now modify the config files. Is there a way to do this via YUNOHOST’S admin panel and if not, is there an alternate way?

thanks so much. I’m so far impressed with this system.

I should add, I have this setup on a linode running Debian 11.x. I also made sure all packages were up to date before installing the yunohost system. I’m just coming back from liniux after an almost 4 year absence so there probably is something I’m forgetting.

Thanks so much.

Accessing app configuration can be achieved via SSH by using sudo command. If you need to modify config to use S3 I’d recommend

sudo -u castopod nano -w /var/www/castopod/.env

This will, as a dedicated castopod user, open the configuration file in nano editor (feel free to use other editor). Navigate to S3 configuration section and change values as needed.

The folder you mentioned, /home/yunohost.apps/castopod is for FS storage, not S3.


Happy wednesday. Thanks for the very speedy reply.
I might need to do this for some of my other apps which require s3 assuming I can get them working. I’ll also have to read about nano again as it’s been a minute. No orries. It will all be a very good relearning experience.
I’m too used to winscp and its internal editor. Wish I could do this in a gui. OH well. Is there a pattern I can use regarding yunohost and the apps for whose config files I need to edit or whose directgories I need to visit to obtain informationsuch as usernames and pass phrases in the future. IO’m still amazed at this system and am excited to learn a lot more.
again thanks.

Good morning. Sorry about the log delay in replying. I’ve been busy at work.
I just tried the steps in the reply, I got the error that I as the current user did not have permission to edit this. This after I typed in the password for the account I’m logged in as. So I can’t complete these steps, at all even “so castopod” fails as I don’t know what pwd (password in this case) yunohost uses by default for such use cases. I don’t feel like getting locked out of my account by accident. Lol! I would I’m on a linode and the SSH was reconfigured after I did the post install script. I want to get this solved, as I love castopod and want to use it along with my s3 storage to better host my content. Is there a way I can do this from the yunohost panel, that is, bring u the config file there for editing since I for what eve reason cannot bring up the file in the terminal?
Thanks so much and happy wednesday.

You can mount your s3 bucket using rclone on /mnt/s3 and mount bind it to /home following this guide (as if it is an external hard drive).