How to create a backup in Nextcloud with Duplicati

Bonjour,
J’ai installé Nextcloud sur une machine cimme serveur domestique avec Yunohost 3.6.4.4.3 Mon nom de domaine est “xxxxxxxx.ynh.fr” et Nextcloud me donne “https://xxxxxx.ynh.fr/nextcloud/remote.php/webdav/” comme adresse pour accéder à mes fichiers via WebDAV.
Je voudrais créer une nouvelle sauvegarde avec Duplicati. Pour ce faire, je dois entrer les paramètres suivants (entre parenthèses mes idées de réponses) :
Type de magasin : (WebDAV)
Utiliser SSL : (OK)
Serveur et port : (https://xxxxxx.ynh.fr)
Chemin d’accès sur le serveur : (nextcloud/remote.php/webdav/Test)
Nom d’utilisateur : (mon utilisateur pour Yunohost)
Mot de passe : (le mot de passe de l’utilisateur)

Pourtant, j’obtiens toujours l’erreur suivante "Failed to connect : Erreur : TrustFailure (échec de l’authentification, voir exception interne.)

J’ai atteint mon niveau d’incompétence… Toute aide est la bienvenue.

Cordialement et longue vie à Yunohost !


Hello,
I installed Nextcloud on a home server machine running with Yunohost 3.6.4.3.My domain name is “xxxxxx.ynh.fr” and Nextcloud gives me “https://xxxxxx.ynh.fr/nextcloud/remote.php/webdav/” as the address to access my files through WebDAV.
I would like to create a new backup with Duplicati. To do this I need to enter the following parameters (in brackets my ideas for answers):
Storage type: (WebDAV)
Use SSL: (OK)
Server and port: (https://xxxxxx.ynh.fr)
Path on the server: (nextcloud/remote.php/webdav/Test)
Username: (my user for Yunohost)
Password: (the user’s password)

Yet, I get always the following error “Failed to connect: Error: TrustFailure (Authentication failed, see inner exception.)

I have reached my level of incompetence… Any help is welcome.

Sincerely and long live Yunohost!

EDIT : It works with the following parameters
Storage type: WebDAV
Use SSL: unchecked
Server and port: xxxxxx.ynh.fr/nextcloud/remote.php/webdav and removing the indication port 443.
Path on the server: Test
Username: my user for Yunohost
Password: the user’s password

It looks like a certificate problem ; I’m still working on it…

1 Like