How to configure navidrome and yunohost to be able to use substreamer

Yunohost server : local Hardware
Yunohost version : 10.0.9.14
SSH and Web acces to the server

I have installed Navidrome and it works perfectly with an internet navigator.

But I want to use Navidrome with the smartphone application Substreamer.

This application want to talk with Navidrome with the Subsonic protocol.

Navidrome is using a special port for Subsonic protocol exchange : 4533

What are the changes I must do to Yunohost to be able to please Navidrome and Substreamer ?

Pascal Levasseur

first, check that 4533 is opened in your ISP router

I have installed Navidrome and it works perfectly with an internet navigator.

have you tried setting port in the URL? https://navidrome.domain.tld:4533

what URL are you using with your browser to access Navidrome? do you need to set port?

Have you tried to also access Navidrome from your mobile device browser? If so, and does not work, then may be that navidrome`s port in not accesible from outside local network

I personally use subtracks, but the client should not be an issue.

Hello,

I have a subdomain pointing directly to Navidrome : musique.xx.yy

1a) I can access Navidrome with my Internet browser smartphone with this URL : https://musique.xx.yy

1b) I can acces Navidrome with Tor Browser with the same URL

So I can access Navidrome with a navigator from the outside world.

  1. Port 4533 TCP is open on the the ISP router and redirectect to the Yunohost server.

3 ) I have opened the 4533 TCP port in the yunohost firewall

  1. I get an « unable to connect » if I try to reach Navidrome with this URL : https://musique.xx.yy:4533

  2. The Navidrome conf file has the line : Port = "4533 »

  3. The NGINX conf file related to Navidrome has a variable named PORT in the place dedicated to the TCP port

  4. Using netcat -v musique.xx.yy 4533 i get an « connexion refused » message either in ipv4 or ipv6

  5. Using netcat -v musique.xx.yy 80 I get a « succeeded » message

  6. Using netcat -v musique.xx.yy 443 I get a « succeeded » message

Thanks for your help.

Pascal

I think the 4533 is the port used by nginx to connect to navidrome but the connection outside is bind to https port normally.
What if you try to connect to https port?

Is Navidrome installed as public app?

cf: navidrome_ynh/manifest.json at 503e032291fa2976d8632485d5496b709c3385b9 · YunoHost-Apps/navidrome_ynh · GitHub

I have made some progress !

  1. I have uninstalled Navidrome

  2. I have made a vanilla install of Navidrome.

3a) I can acces the Yunohost application menu with an Internet navigator through the Yunohost login screen.

3b) Then I can acces Navidrome by clicking th e Navidrome box in the Yunohost menu

3c) I have to fill the login screen of Navidrome to be able to acces it.

  1. Now, the best for the end … I can acces Navidrome and play music with Substreamer using this URL → https://musique.xx.yy/navidrome:4533

Happy end. Thank very much for your help.

Is there any way the Yunohost/Navidrome doc could be updated with some informations to help the futures poor souls like me who will try to connect Yunohost / Navidrome with Substreamer ???

Regards

As I don’t liked the double identification stages the vanilla installation setup, I went to the “application” menu of the YunoHost administration menu and I enable the “Rediriger la racine de ce domaine sur cette application” option.

I now have a single step of identification, the Navidrome one, and Substreamer is still working as a charm.

1 Like