How do we do a rebuild of jupyterlab on yunohost?

HI,
This doesn’t apply to a specific platform.

How do we run a “jupyter lab build” when a rebuild has failed when installing an extension on yunohost?
Jupyter is not a command recognized in CLI.

Bonjour,
Normalement cette question n’est platform-specific.

Comment fait-on tourner la commande “jupyter lab build” quand le bouton rebuild lors de l’installation d’une extension, échoue ?
En CLI jupyter n’est pas une commande reconnue.
Donc en gros comment recharge-t-on un environnement jupyter sur yunohost ?

Merci d’avance

Tente d’exécuter la commande dans un onglet “Terminal” dans Jupyter Lab.

Non, ça il me dit que jupyter est pas installé et qu il faut que je demande à l administrateur d’installer jupyter-core

Une autre idée ?

Tente

cd /opt/jupyterlab
source .venv/bin/activate
source /usr/share/yunohost/helpers
app=jupyterlab
ynh_use_nodejs
jupyter lab build

Bon j’ai essayé:
J’ai ça :

(jupyterlab) root@dev:/opt/jupyterlab# more /tmp/jupyterlab-debug-tg3tpebo.log
[LabBuildApp] Building in /opt/jupyterlab/.venv/share/jupyter/lab
[LabBuildApp] Node v10.21.0

[LabBuildApp] Yarn configuration loaded.
[LabBuildApp] Building jupyterlab assets (build:prod)
[LabBuildApp] > node /opt/jupyterlab/.venv/lib/python3.5/site-packages/jupyterlab/staging/yarn.js install --non-interactive
[LabBuildApp] yarn install v1.21.1
[1/5] Validating package.json...
[2/5] Resolving packages...
success Already up-to-date.
Done in 14.92s.

[LabBuildApp] > node /opt/jupyterlab/.venv/lib/python3.5/site-packages/jupyterlab/staging/yarn.js yarn-deduplicate -s fewer --fail
[LabBuildApp] yarn run v1.21.1
$ /opt/jupyterlab/.venv/share/jupyter/lab/staging/node_modules/.bin/yarn-deduplicate -s fewer --fail
Done in 6.93s.

[LabBuildApp] > node /opt/jupyterlab/.venv/lib/python3.5/site-packages/jupyterlab/staging/yarn.js run build:prod
[LabBuildApp]
[LabBuildApp] JupyterLab failed to build
[LabBuildApp] Traceback (most recent call last):

[LabBuildApp]   File "/opt/jupyterlab/.venv/lib/python3.5/site-packages/jupyterlab/debuglog.py", line 47, in debug_logging
    yield

[LabBuildApp]   File "/opt/jupyterlab/.venv/lib/python3.5/site-packages/jupyterlab/labapp.py", line 138, in start
    raise e

[LabBuildApp]   File "/opt/jupyterlab/.venv/lib/python3.5/site-packages/jupyterlab/labapp.py", line 135, in start
    command=command, app_options=app_options)

[LabBuildApp]   File "/opt/jupyterlab/.venv/lib/python3.5/site-packages/jupyterlab/commands.py", line 460, in build
    command=command, clean_staging=clean_staging)

[LabBuildApp]   File "/opt/jupyterlab/.venv/lib/python3.5/site-packages/jupyterlab/commands.py", line 661, in build
    raise RuntimeError(msg)

[LabBuildApp] RuntimeError: JupyterLab failed to build

[LabBuildApp] Exiting application: JupyterLab 

Une idée de ce que ça veut dire?

@TitusPiJean et merci encore de m’aider pour ça.

Aucune idée donc ? J’aurais voulu régler le problème avant la migration vers 4.0