Homarr instace breaks if updated from 0.13.2~ynh1 to 0.13.4~ynh1


My name is Boris and I come from Slovenia.
I am running YunoHost service on a VM machine (HyperV), using YunoHost for over 5 years now, and I am generally very satisfied with your service.

Let me go straigt to my problem…

I am having issues with Homarr when trying to do an update/upgrade.
My istance of Homarr breaks when I run the updating process through YunoHost Admin panel.
After running update “Homarr (homarr) from 0.13.2~ynh1 to 0.13.4~ynh1” Homarr service can no longer start, and I can not figure what is the problem causing Homarr to break. Nothing that I could figure out from logs.
This has already happened to me with an older update, but I circumvented it by removing the existing instance and doing a fresh install… but this is not a very pleasant solution as I have to re-configure the whole thing from zero.
Oh yes… my Homarr instance is quite heavily modified through custom CSS. But I’ve tried this with a clean instance of Homarr, and I get the same result… Homarr service would not start after the update.

You can check out my Homarr page by visiting https://home.multibox.theworkpc.com/ - current version 0.13.2~ynh1.

If you need any aditional info please tell me what you need. I am pretty much clueless to what the problem could be.

With best regards, Boris B.

Hi Boris,
Unfortunately, we can’t help you without proper logs!
Can you upgrade to 0.13.4~ynh1 and share logs from the upgarde and from the homarr service (using YunoPaste) ?

1 Like

Hey! Thank you for very fast response! :smiley:

I hope it’s ok to use my private instance of “Haste” paste-bin.
…pasting here would be a bit too much. I can post them here directly if you wish.

YH upgrade log
Homarr service log

I hope this is what you expected?


Just passing by : the actual error message from journalctl seems to be :

yarn[262835]: command not found: next

But i don’t know enough about yarn / next to know what this is / means

1 Like