Help with domain - Galène


I am looking for some help with my instance while using Galene. My yunohost is working fine and I have installed Galene as a private videoconferencing tool for my work. This works fine and I can add users with no problem. They can access the conferencing.

My problem is that Galene does not allow me to use yunohost for anything else. I have tried to install navidrome to run a subsonic client but the server will not allow it.

When I type in my server in the browser - XXXX.Domain.tld - it directs me straight to Galene. It does not bring me to the yunohost app interface.

I uninstalled the Galene app and installed navidrome first, followed by galene. Both installed fine but when I put in my domain with galene - xxxx.domain.tld/galene - it directed me the app interface.

This means that when I give clients the galene link for video conference, they are directed to the app interface and not the galene interface.

Does anyone know how to resolve this? I would like to have more app functionality on my server but Galene does not seem to allow it!!

Thanks for any help.

@lsjmhar I am not sure to understand fully your setup but Galène needs a domain or subdomain on its own (like Something like is not allowed).
Then you need to make sure to set Galène as public app during the installation process, otherwise visitors will be redirected to the SSO page …
Navidrome can be installed in a sub-folder like
I hope this help.

In fact it does allow you to install anything else on the same domain (which can be a subdomain (XXX.domain.tld)).
You need to install the other apps using another domain.

It sounds like you installed Galene on your main, default domain (publicly, not behind SSO), and at its root (not a /folder). Hence by default your Yunohost domain redirect to the only app on that domain, Galène.

You need to use another domain/subdomain for other apps, and maybe a different default one.

Thanks for that. I think I need to do a complete reinstall as I am having trouble with my Letsencrypt Cert also. I have a valid cert installed but the GUI tells me it is outdated and not valid.

This is what happens from tinkering around the edges of servers. Lol!!


I have reset my server and put both nextcloud and navidrome on my default domain.

I created a new domain for galene and I can access it on my network after dns configuration on my router. However, diagnostic assessment tells me I have an dns issue and I cannot install a letsencrypt cert.

I cannot access the domain outside my network at all. Any idea what could be wrong?

What 's the issue with dns?


I am having constant issues. I have installed galene on my default domain - xxxx.domain.tld.

I have now tried to install navidrome as a subdomain to this - navidrome.xxxx.domain.tld.

I can access the navidrome site from outside my network now but I cannot access galene - browser says page not found. I can access galene in my LAN.

From my experience of galene I can only get it working properly if I create a complete server for it - RPi3. It appears I need a separate server for other apps - another RPi.

Has anybody experience on using galene on their server while also using other apps - nextcloud, ampache, navidrome, ttrss. If so, a step-by-step guide would be beneficial as I have tried several methods and none seem to allow this.


As said above, galène needs a dedicated domain so you’ll have to create a new subdomain galen.xxxx.domain.tld for it.
I never used it before but I have some apps that require a dedicated domain.

If I understand correctly, you have yunohost installed on xxxx.domain.tld, then you should have nothing else installed on this domain unless it is in a sub-folder (and the app does not require a dedicated domain).

Thanks so much. I understand it now. I have to create separate subdomains for each app. I have galene and navidrome installed and can access both!!!

Just one more thing. How do I get letsencrypt on each subdomain to stop the risk message appearing for other users. I have a letsencrypt cert on my xxxx.domain.tld.

I now want to put one on galene.xxxx.domain.tld. Any time I have tried to force it through the terminal it has not worked. The gui won’t allow me to do it either and gives me a 404 error, site not found.

After creating the new subdomain you’ll have to run the system diagnosis, see if there is any problem. Then go to domains > choose the domain that needs to have the certificate > ssl certificate > generate a new letsencrypt one.
Sometimes you’ll have to wait for minutes before you see that you can generate the certificate.


This is the error I am getting when trying to install letsencrypt on any of the subdomains.

Wrote file to /tmp/acme-challenge-public/lf2UEYzzJf8ib5iPfZte4Y_sr-9zG38sx4KWIofOiV4, but couldn’t download http://galene.xxxx.domain.tld/.well-known/acme-challenge/lf2UEYzzJf8ib5iPfZte4Y_sr-9zG38sx4KWIofOiV4: Error:
Url: http://galene.xxxx.domian.tld/.well-known/acme-challenge/lf2UEYzzJf8ib5iPfZte4Y_sr-9zG38sx4KWIofOiV4 Data: None Response Code: 404 Response:

404 Not Found

File not found.

Any ideas on what to do to resolve this?

You may need to add a line to your hosts

sudo nano /etc/hosts

Go to the end and add galene.xxxx.domain.tld xmpp-upload.galene.xxxx.domain.tld

And save. Then retry certificate generation.


That worked perfectly. All is functioning now.

:+1: :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.