HedgeDoc upgrade failed

My YunoHost server

Hardware: Old computer at home
YunoHost version: 11.1.20
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: HedgeDoc 1.9.7~ynh3

Description of my issue


I’m trying to upgrade HedgeDoc from Version 1.9.7~ynh3 to Version 1.9.8~ynh1. It fails with
FATAL ERROR: Reached heap limit Allocation failed - JavaScript heap out of memory.

This is the log: https://paste.yunohost.org/raw/uqasulebak

Here is a problem with the same error message where it was assumed that there was not enough memory:

But my server already uses an 8G swap file:

sudo swapon -s && echo && free
Filename            Type            Size    Used    Priority
/swapfile           file            8388604 803384  -2
/dev/dm-1           partition       999420  0       -3
/dev/zram0          partition       262140  262132  100

               total        used        free      shared  buff/cache   available
Mem:         1938512     1486816       70588       21796      381108      279012
Swap:        9650164     1067828     8582336

Shouldn’t that be sufficient? Any ideas what I could try?

I am having the same issue.

YunoHost version:

I just tried increasing my swap from 2GB to 4GB and it still failed, but it sounds like 8GB isn’t even enough! :grimacing: :sweat_smile:

Also wondering if anyone has any idea on how to fix this! :smiley: :crossed_fingers:

I did a little digging into this, and it seems there have been issues in the past trying to run or install HedgeDoc with 2GB (or less) of memory. (I only have 2GB of physical memory.)

1 Like

@pqc Thanks for your investigation!

There is also this:

It seems adding more Swap doesn’t solve the problem while adding more RAM helps.

I don’t think, though, that adding more RAM is a good solution as long as this is only needed for upgrading an app. Everything is working well on my YunoHost except upgrading HedgeDoc. Using HedgeDoc works without any problems and I’m using it a lot.

Why isn’t it sufficient to add more Swap instead of RAM?
And why is HedgeDoc built on YunoHost instead of providing a prebuilt version?

Thanks in advance for any info / ideas / thoughts / workarounds …

1 Like

Should be fixed in the next update


Good find @snm! Thanks for the update @ericg!

:raised_hands: :heart:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.