HedgeDoc Update Fails 1.9.5 -> 1.9.6

My YunoHost server

**Hardware: Raspberry Pi 4 with 4Gb
YunoHost version: 11.1.0.2
**I have access to my server : Through SSH or WebAdmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

When I check for updates I am told there is an update to HedgeDoc:

Docs (hedgedoc) from 1.9.5~ynh1 to 1.9.6~ynh1

When I try to install there is a cascade of errors and the install fails
https://paste.yunohost.org/raw/idilohobiq (log for the failed update)

The update attempt backs out safely. I am also unable to install a second instance on a different domain on the same server.
https://paste.yunohost.org/raw/dezuruvebi (log of failed install)

I’ve now worked my way through the log and find it appears to be some action involving yarn that fails, but I do not have the necessary skills to work out how to fix it. I have run all the recommended commands in the log files but it still won’t upgrade. Most recent log:
https://paste.yunohost.org/raw/wupiwipuqa

Issue is at line
2022-11-16 09:46:35,895: WARNING - error Command failed.

At this point I don’t know what to try to fix it any more.

It is very strange, the error say you can’t git pull. Why in the script you need git pull ??

Command: git
2022-11-16 09:46:35,900: WARNING - Arguments: pull
2022-11-16 09:46:35,902: WARNING - Directory: /usr/local/share/.cache/yarn/v6/.tmp/f288a63eaa4f5075285a1b09fb58c8f0
2022-11-16 09:46:35,904: WARNING - Output:
2022-11-16 09:46:35,906: WARNING - error: Pulling is not possible because you have unmerged files.
2022-11-16 09:46:35,908: WARNING - hint: Fix them up in the work tree, and then use 'git add/rm <file>'
2022-11-16 09:46:35,910: WARNING - hint: as appropriate to mark resolution and make a commit.
2022-11-16 09:46:35,913: WARNING - fatal: Exiting because of an unresolved conflict.

Do you have use git to push yours modifications ??

Looks like it’s not just you I’m running into the same issue here trying to update HedgeDoc.

2022-11-19 23:44:41,646: WARNING - fatal: Exiting because of an unresolved conflict.

I have the exact same error with the same update.

Same problem with upgrade… Hedgedoc is now totaly down ( Welcome to nginx!)
https://paste.yunohost.org/raw/utasokopot

Update: HedgeDoc running (version 1.9.4) after a star/stop

Solution found on Github

Connected to the server with SSH and using CLI:

sudo yarn cache clean

sudo yunohost app upgrade hedgedoc

Now Hedgedoc is up and running

1 Like

Thanks for passing along this info! This worked for me as well! :tada: :raised_hands: :smiley:

Unfortunately it did not fix things here. I have tried removing and reinstalling HedgeDoc now, and I can’t get it to install either - I had to restore the backup to get working. I wonder if it is related to the false “upgrade” to 11.1.