Hedgedoc install fails on Rasp4 (Chromium related issue)

:uk:/:us: Hedgedoc install fails

My YunoHost server

Hardware: Raspberry PI 4 (4Go RAM, 64Go storage)
YunoHost version: 11.1.19 (stable)
I have access to my server : Through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : Yes
If yes, please explain: This yunohost install is only on a local network machine, not on a distant server
If your request is related to an app, specify its name and version: HedgeDoc 1.9.7~ynh3

Description of my issue

HedgeDoc installation fails, here is the complete log : https://paste.yunohost.org/raw/okalufevov

It seems related to Chromium install, but I don’t know how to solve this.

Thank you !

:fr: L’installation d’HedgeDoc échoue

Mon serveur YunoHost

Matériel: Raspberry PI 4 (4Go RAM, 64Go stockage)
Version de YunoHost: 11.1.19 (stable)
J’ai accès à mon serveur : Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : oui
Si oui, expliquer: Yunohost est installé sur une machine de mon réseau local et non sur un serveur distant
Si votre requête est liée à une applicatio, précisez son nom et sa version: HedgeDoc 1.9.7~ynh3

Description du problème

Je n’arrive pas à installer HedgeDoc. Voilà le log complet : https://paste.yunohost.org/raw/okalufevov

Le problème a l’air d’être lié à l’installation de Chromium mais je ne vois pas trop ce qu’il faut que je fasse pour le résoudre.

Merci pour votre aide !

Unfortunately it seems like the app ain’t compatible with arm64 because : « The chromium binary is not available for arm64. »

Not sure why chromium is needed, by rough guess is that it’s related to some PDF export feature

Oooooor maybe you can try apt install chromium (but I’m guessing this will also install a shitload of dependencies) and retry the app install

Hello, thank you for your answer !

I ran apt install chromium (and you were right, it’s very big : it takes almost 500Mb).

Then I tried again to install HedgeDoc, and this time the error is different, here is the log : https://paste.yunohost.org/raw/ubirokukiy

May be this line is the most important one ? fatal: unable to access 'https://github.com/hedgedoc/js-sequence-diagrams.git/': gnutls_handshake() failed: The TLS connection was non-properly terminated. Could it be related to my yunohost install being local only ?

Thanks !

there is an issue opened App fails to install if Chromium not present on the server · Issue #52 · YunoHost-Apps/hedgedoc_ynh · GitHub

It seems related but people seem to be able to fix their issue by installing chromium separately (“Just to confirm that installing chromium via terminal did allow me to successfully upgrade afterwards.”). However I can’t : chromium installation works well but then I get another error while installing HedgeDoc (https://paste.yunohost.org/raw/ubirokukiy).

I installed Chromium and tried to install Hedgedoc with PUPPETEER_SKIP_DOWNLOAD env var to true as suggested on the github page you mentioned.

But it still fails, here is the log : https://paste.yunohost.org/raw/filowosugi

Do you know another workaround I could try?


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Hi, I’m still stuck with this issue. Thank you @Aleks for reopening it.

Is there anything else I could try ?