Hedgedoc install error

My YunoHost server

Hardware: Old laptop or computer
YunoHost version: 11.2.5
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: hedgedoc 1.9.9~ynh2

Description of my issue

Hi, I’m trying to configure Hedgedoc and seeing this:

The full text is:

An error prevents the configuration panel from being displayed:

Config panel question 'require_free_url_authentication' should be initialized with a value during install or upgrade.

Please report this error to the YunoHost team to get it fixed!

I’d appreciate any help and would also be grateful if someone knows how to fix this through the command line.

Addendum: The app works just fine, I can access Hedgedoc and create new documents etc. I can’t currently log in to the app overview (the non-admin Yunohost interface where you can choose between the apps) and I don’t know if that might be related to this.

Access to Yunohost Admin obviously works.

Hmmokay, can you try to share the output of : sudo grep requireFreeURLAuthentication /var/www/hedgedoc/config.json ?

1 Like

Hi Aleks,

thanks for replying! Indeed I can:

agger@apps:~$ sudo grep requireFreeURLAuthentication /var/www/hedgedoc/config.json 

I.e., no output.

with cat /var/www/hedgedoc/config.json

what do you have for the requireFreeURLAuthentication entry?

That’s what I meant with my earlier reply - the string requireFreeURLAuthentication is not found in that file.

These are the contents of the file:

    "production": {
        "protocolUseSSL": true,
        "domain": "xxx.yyy.zzz",
        "port": "3000",
        "urlPath": "hedgedoc",
        "loglevel": "info",
        "useCDN": false,
        "allowGravatar": false,
        "allowFreeURL": true,
        "allowAnonymous": true, 
        "allowAnonymousEdits": true,
        "defaultPermission": "locked",
        "email": true,
        "allowEmailRegister": true,
        "imageUploadType": "filesystem",
        "tooBusyLag": 1000,
        "hsts": {
            "enable": true,
            "maxAgeSeconds": 31536000,
            "includeSubdomains": true,
            "preload": true
        "csp": {
            "enable": true,
            "directives": {
            "upgradeInsecureRequests": "auto",
            "addDefaults": true,
            "addDisqus": true,
            "allowFraming": false,
            "addGoogleAnalytics": false
        "minio": {
            "accessKey": "",
            "secretKey": "",
            "endPoint": "localhost",
            "port": 9000,
            "secure": false
        "db": {
            "username": "dfdfdfd",
            "password": "1aGER2MGQjCodfdsfdfd0tbLF",
            "database": "hedgedoc",
            "host": "localhost",
            "port": "5432",
            "dialect": "postgres"
        "ldap": {
            "url": "ldap://",
            "bindDn": null,
            "bindCredentials": null,
            "searchBase": "ou=users,dc=yunohost,dc=org",
            "searchFilter": "(&(|(objectclass=posixAccount))(uid={{username}})(permission=cn=hedgedoc.main,ou=permission,dc=yunohost,dc=org))",
            "usernameField": "cn",
            "useridField": "uid",
            "providerName": "YunoHost"

You can manually add it by editing the config file according to the sample: https://github.com/YunoHost-Apps/hedgedoc_ynh/blob/master/conf/config.json.example.
add restart the Hedgedoc service.

Thanks a lot, that fixed it! I wonder how it went missing, though - I haven’t been editing this file manually.

I suspect this setting line was added more or less recently. The config file is not regenerated during upgrade. This should be fixed.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.