Grav update and 2 PHP versions on Yunohost

Hi there,

I just installed Grav and want to update it:
v1.5.10 > v1.6.23

Unfortunately, it doesn’t work.
It says that PHP 7.1.3 is required, but that I am on 7.0.33.

I made a diagnosis of my server (currently Yunohost and found out that I have 2 PHP versions enabled:

“services”: {
“php7.3-fpm”: “running (enabled)”,
“php7.0-fpm”: “running (enabled)”,


  • Why do I have 2 PHP versions at the same time on Yunohost?
  • Why Grav only recognises the older one?
  • Is there a way to make Grav recognise the newer one, in order to be able to update this app?

Thank you very much for your help!

Php7.0 is what’s shipped by default in Debian Stretch. But some apps do add extra repo stuff to install php7.3 because they require it.

Because the app wants 7.1 specifically. It could probably work on 7.3, yes, but it’s not that simple under the hood.

Yes and no. The real question would be to understand why Grav doesn’t install php7.1 like it should.

And to do so, you should do what is advertised at least at 3 differents places in this forum (among which the support question template you didn’t use), which is to give us the damn log

What’s “it”


To complement @Aleks’ answers, what you are doing is asking Grav to update itself (because it says it can), while the recommended way is to let YunoHost handle the upgrade. Usually it is not an issue for minor upgrades, but here the change is significant.

As stated above, PHP versions handling is a bit tricky right now, but is being worked on. I have a development branch that installs PHP7.3 and enables logging in with your YNH credentials. You can install it for testing purposes, as I am still struggling with the upgrade part.

Hi both,

Thank you for your replies and explanations.

Sorry for this, I thought that my questions were too general to need more specific information.
Here is more info:

Hardware: Raspberry Pi at home
YunoHost version:
I have access to my server : through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Regarding the log, it is not reflected on Yunohost as the server considers Grav as up to date.
This update is requested on the Grav’s dashboard.
I tried again and there is no mention of this failure on Yunohost logs.
Here is the full message I get:

Grav update failed

Grav has increased the minimum PHP requirement.
You are currently running PHP 7.0.33-26+0~20200320.33+debian9~1.gbp746b8e , but PHP 7.1.3 is required.

Is there a way in the app to get logs?

The update

Mh… so if I understand well, it would be safer for me to simply wait for the next update available on Yunohost, right? (taking into account that my knowledge in this area remains pretty limited)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.