GPLI update fails

Since a few months I’m unable to update GPLI. Yunohost is completely updated. This is the log:

Just a small question : why did you delete the template for a question in support ?

I know most information can be found in your log, but please, just follow the rules :pray:

From what I can see, some requirements are missing :

Some mandatory system requirements are missing. Run the “php bin/console system:check_requirements” command for more details.

It seems that you are not alone with this problem : Update 10.0.6 -> 10.0.10 fails · Issue #23 · YunoHost-Apps/glpi_ynh · GitHub
And this issue too : Mise à jour 10.0.6 en echec · Issue #14 · YunoHost-Apps/glpi_ynh · GitHub
In this one, there are some workaround, but they should not be used and instead someone should update the code with these dependencies.

edit2 : line to update in case those requirements are the real solution : glpi_ynh/manifest.toml at testing · YunoHost-Apps/glpi_ynh · GitHub
I can do them if you want to try an upgrade with a testing version, but I have no test server to validate it.

I just checked, and the second topic is outdated, those dependencies are already listed, so it may be something else, maybe you can try to have a look for the dependences.

(And maybe you should use php8.2 and not just php, I have no idea where the used php version is defined in this repo, but the dependencies requires 8.2. (but according to the topic with dependencies, maybe the dependencies are installed in 8.2 but php 8.0 is used ? ))

edit : if phpX.Y-something is listed in the dependencies, phpX.Y will be used, so wrong suggestion, sorry :frowning:

Because I opened the link to the guidelines and used that for creating the post, and the French text in between is distracting me.

Then, remove the text in french, and keep the english template :smile:
You opened 3 topics, and none of them have the template (one have an absolute minimum version of the template).

The absence of template is distracting me :person_shrugging:

It’s done automatically if a dependency is formatted like that php8.2-something, yunohost know that the package is using php8.2 ^w^

Edit: ah … just seen your edit lol

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.