GoToSocial Access to Admin Panel

My YunoHost server

Hardware: Old laptop
YunoHost version: 11.2.3 (stable)
I have access to my server : through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi All, and thanks for your great efforts in Yunohost.

I’m hosting my own GoToSocial instance (v. 0.11) and I’m trying to access the GTS admin panel via the - GoToSocial page.

Once I enter my log-in credentials and then click Allow, I’m getting the “401: Unauthorized: token not supplied” error message, as shown in the attached pic.

I also read the Admin documentation Admin Settings - GoToSocial Documentation and tried the command:

./gotosocial --config-path ./config.yaml admin account promote --username YOUR_USERNAME

Which returns the timestamps below:

So, I’m not sure what I’m doing wrong. Or perhaps in its current state, I shouldn’t be able to access my admin panel, but only the config panel through Yunohost’s interface?

Thanks in advance for your help.

Does it work if you go here?

With the public instance link, it gives me this error message instead:

FYI - All my adblockers, VPN are off so there’s no interference from them.

Problem was solved by switching browsers (From FF to Edge). Then I logged in via the original link - GoToSocial.

I find it really weird though, as both browsers have the same (default) settings, unless smth in FF’s settings is blocking the auth API :unamused:

Anyhoo, apologies for this false alarm.


It works for me in Firefox (latest stable version, 116). So there is something else.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.