Glitchsoc upgrade fails

My YunoHost server

Hardware: Old laptop
YunoHost version:
I have access to my server : full access
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi there,

Did anyone else have trouble upgrading glitchsoc from 2022.06.16~ynh1 to 2022.07.27~ynh1?

I tried a couple of times but it fails. Logs here:

Cannot sort out where it fails.

Any tips would be welcome. Thanks!

Zblerg sounds like it’s a bug in some lib and some specific CPUs … [BUG] Illegal instruction

This is discussed here oj gem 3.13.15+ causes an illegal instruction on CPUs that do not support SSE4.2 · Issue #789 · ohler55/oj · GitHub

and apparently this was fixed in the lib’s version v3.13.20 but for some reason the install is Fetching oj 3.13.17

smol poke @Tagada if you have some ideas on how we can fix this

1 Like

Mmmmmmh this sounds like it should be fixed by Disable SSE 4.2 compile instructions by default by stanhu · Pull Request #806 · ohler55/oj · GitHub which was merged in 3.13.20 released on 08/08/2022 :thinking:
and Mastodon should use this version now !

@josh Could you try to upgrade to the last package version I just released ?

1 Like

@Tagada The package version # hasn’t changed on my side.

Should I upgrade to the testing branch?


Ok the new version showed up 2022.08.01~ynh1
Sorry it completely froze the server, still upgrading after some hours.
I can hear disk and wild fan activity but it’s otherwise completely unresponsive, had to force shut it and restore glitchsoc from backup. After reboot Seafile is also broken.

2022-08-30 03:28:48,589: DEBUG - Compilation failed:
2022-08-30 03:28:51,650: DEBUG - Browserslist: caniuse-lite is outdated. Please run:
2022-08-30 03:28:51,650: DEBUG - npx browserslist@latest --update-db

Sleepy time for me, will try that tomorrow.

EDIT: Could not restore Seafile

Apparently this has to be done is a specific directory, but I have no clue which that would be :roll_eyes:

Upgrades are still not coming through, latest is 08/01 which fails. Rooting for @Tagada ! Fingers crossed.

1 Like

Mmmh you could try this:

cd /var/www/glitchsoc/live/
sudo -u glitchsoc npx browserslist@latest --update-db
1 Like

Success! Thank you!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.