GitLab: suddenly I cannot clone | push | pull any project using SSH keys

My YunoHost server

Hardware: (Old) computer
YunoHost version: (stable)
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue


I use Yunohost and GitLab since about 2 years. I have provided SSH keys for each client I use in my projects. When cloning, pushing or pulling I was asked to enter the SSH keys password. This worked smoothly.

Since a few days (weeks? - there was a longer break in using GitLab) the SSH keys are completely ignored and I am asked to enter the git password instead - what I don’t have.
I think this is a result of one of the last updates within Yunohost System. I have currently trouble with upgrading GitLab which is handled in a seperate Thread. As I still run the old GitLab version (13.3.4~ynh1) which still works perfectly I think something within Yunohost system changed and causes the SSH key problem for GitLab app.

I tried to delete a client Key and added a new one for that client but it behaves identically, asking for git password.

esp32-ota-template % git push --verbose git@yunohost.local:helmut/esp32-ota-template.git
Pushing to yunohost.local:helmut/esp32-ota-template.git
Debian GNU/Linux 10
git@yunohost.local's password: 

The keys work as usual when logging in on Yunohost console.

I hope someone can help me to solve this problem

Thanks a lot in advance

Is there no idea what’s going wrong?

What version did your Yunohost come from? The first thing I thought of is a relatively recent addition is management of SSH access via user groups, maybe the introduction of those user rights messed up the existing configuration for Gitlab?

(bottom half: the manage-groups-button, top half: create a group
or users with SSH access)

Then again, if you still can log on via SSH with these accounts, that could not be the problem.

Could it be that the git on the client got an update, and is not using a certain family of keys anymore? What is there in the SSH log, serverside?

As I have several different clients and all behave identically, I’m pretty sure that not a change on these clients causes the problem.
On the other hand my last Yunhost Migration was “Support for SSH and SFTP Rights”, so I think you may be right that this caused the trouble with Gitlab.

If so, how can it be solved?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.