Ghost update fails

My YunoHost server

Hardware: VPS bought online
YunoHost version:
I have access to my server : Through SSH | through the webadmin

Description of my issue

I have two installs of Ghost. One updated fine. The other not. Trying to go from 5.8.3 to 5.17.0

The log is here:

What went wrong?

Am I the only one? Any suggestion how to reinstall without loosing my data?

Not sure what happens exactly, but this seems to be the original issue:

2022-10-05 09:10:31,869: DEBUG - $ ember build --environment/production
2022-10-05 09:10:38,385: DEBUG - The option '--environment/production' is not registered with the 'build' command. Run `ember build --help` for a list of supported options.
2022-10-05 09:10:41,817: DEBUG - - Building
2022-10-05 09:10:41,818: DEBUG - Environment: development
2022-10-05 09:10:41,818: DEBUG - - Building
2022-10-05 09:10:41,818: DEBUG - - building...
2022-10-05 09:10:43,338: DEBUG - - cleaning up
2022-10-05 09:10:43,339: DEBUG - cleaning up...
2022-10-05 09:10:43,339: DEBUG - - cleaning up
2022-10-05 09:10:43,367: DEBUG - Build Error (broccoli-persistent-filter:Babel > [Babel: @ember/test-helpers]) in @ember/test-helpers/-internal/debug-info-helpers.js
2022-10-05 09:10:43,367: DEBUG - 
2022-10-05 09:10:43,367: DEBUG - EACCES: permission denied, mkdir '/tmp/root/if-you-need-to-delete-this-open-an-issue-async-disk-cache/6346c7709a799322a36792f51efe49459110ec5e'
2022-10-05 09:10:43,367: DEBUG - 
2022-10-05 09:10:43,371: DEBUG - 
2022-10-05 09:10:43,371: DEBUG - Stack Trace and Error Report: /tmp/error.dump.d815bb82fe700d1b589bb4ceb8446a36.log
2022-10-05 09:10:43,445: DEBUG - error Command failed with exit code 1.

Thanks for replying. I’m also not sure, but after failing both via cli and browser,today it just updated after hanging for quite some time. It’s a 3 core, 4GB vps, perhaps that update wants to use more than that? Ghost is always quite slow in updating I find.

Had exactly the same error :sob: . What strikes me is that the first time I installed Ghost it worked like a charm, but when trying to install a second one it failed with this broccoli error.

I removed the first app, and tried to reinstall it, but it failed with the same mistake. I made an issue about it here : Error at install on installing a Ghost instance : `Build Error (broccoli-persistent-filter:Babel > [Babel: @ember/test-helpers])` · Issue #195 · YunoHost-Apps/ghost_ynh · GitHub. Don’t hesitate to react on it.

EDIT : solved by upgrading to YunoHost 11.x + cleaning space on the VPS disk

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.