Ghost + Stripe : Paypal / Apple Pay validation error

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.10.3 (stable)
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi,
sorry to bother you for something that maybe is a simple redirect issue, but I don’t know how to address it.

I installed Ghost and connected Stripe to get payements. I would like to add Paypal as a payement method on the Stripe page that appears when you try to subscribe.
In order to add Paypal as a payement method, you have to verify your domain (even if Stripe clarifies that this verification is only for Apple Pay). The verification process is:

The problem is that once you upload the file in the correct location, an error appears, saying that when testing, you are redirected to yourdomain.xyz/yunohost/sso.
The entire error message is (the translation is mine!)

Impossible to verify the ownership of yourdomain.xyz. The attempt in requesting https://yourdomain.xyz/.well-known/apple-developer-merchantid-domain-association has been redirected to https://yourdomain.xyz/yunohost/sso/?r=aHR0cHM6Ly9sZWdhaXRhbGlhbmFwb2V0cnlzbGFtLml0Ly53ZWxsLWtub3duL2FwcGxlLWRldmVsb3Blci1tZXJjaGFudGlkLWRvbWFpbi1hc3NvY2lhdGlvbg==. The verification file has to give a 200 status code on https://yourdomain.xyz/.well-known/apple-developer-merchantid-domain-association to register yourdomain.xyz. Did you want to register yourdomain.xyz? For more informations, look at our guide for domain verification Apple Pay.

(and the guide just explains the steps you already followed).
How can I make this file accessible from outside for this test?
Thanks and sorry again for bothering you

You are being redirected to the SSO because you have not registered that path as an app.

Let’s try this: you should create a My Webapp to that location and upload the file in the app’s directory to replace the existing index.html. Installation settings for the app should be:

  • domain : yourdomain.xyz
  • path: .well-known/apple-developer-merchantid-domain-association
  • enable SFTP if you need to upload the file like that
  • PHP: none
  • Database: none

Hi and thanks for the answer. I’ve followed your instructions but there’s something I cannot fix.
I tried to install my webapp with your parameters, and I could reach the path and see that the installation was successfull.
But when verifying I got an error message saying:
Impossible to verify the ownership of yourdomain.xyz. The attempt in requesting https://yourdomain.xyz/.well-known/apple-developer-merchantid-domain-association has been redirected to My Webapp. The verification file has to give a 200 status code on https://yourdomain.xyz/.well-known/apple-developer-merchantid-domain-association to register yourdomain.xyz. Did you want to register legaitalianapoetryslam.it? For more informations, look at our guide for domain verification Apple Pay.

The only discrepancy I could see was the “/” at the end, so I tried to put the file in the “.well-known” folder, not in a subfolder with the name of the file (like every other file there). But nothing changed. Same error message.
I tried to install My Webapp with just “.well-known” as a path, so that if you fetch a file within, you’re not forced to have a “/” in the end, but the original error came back, the verification ended up on “yourdomain.xyz/yunohost/sso”.
Is there a way to make the file considered as a file and not as a folder? (or am i misconsidering the situation).
Thanks again

I had hoped the trailing slash would not affect the verification. Can you confirm the path is accessible by visitors?

yes, Visitors and All Users

I am working into integrating this directly in the app. I’ll keep you in touch when I succeed. (Right now I can upload the file, but cannot serve it at the .well-known location)

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.