Ghost fails installing


Ive some troubles installing ghost.

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.4. (stable)
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:
If your request is related to an app, specify its name and version: ghost 5.61.3~ynh2

Description of my issue

Ive tried to install ghost, but it fails with some warnings and error.

Here my logfile:

Has someone any idea how to solve this issue?



It is weird this error has not been caught by the automated tests, but let’s fix that. :slight_smile: Try running this version of the app:

sudo yunohost app install -f


@tituspijean Thanks for the sudo-line :slight_smile:
I tried this one, but without success :frowning_face:
I assume the node-version has still some troubles …

Warning: Here's an extract of the logs before the crash. It might help debugging the error:
Info: DEBUG - One or more errors occurred.
Info: DEBUG -
Info: WARNING - 1) Checking system Node.js version
Info: DEBUG -
Info: WARNING - Message: The version of Node.js you are using is not supported.
Info: WARNING - Supported: ^12.22.1 || ^14.17.0 || ^16.13.0 || ^18.0.0
Info: WARNING - Installed: 20.7.0
Info: WARNING - See for more information
Info: DEBUG -
Info: DEBUG - Debug Information:
Info: DEBUG -     OS: Debian GNU/Linux, v11
Info: DEBUG -     Node Version: v20.7.0
Info: DEBUG -     Ghost-CLI Version: 1.24.2

The full log is here:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.