Ghost certificate!


I use Let’s Encrypt and the script for auto-renewal with cron.
Everything is fine, but…
I also use SMS Backup + on my cell phone, and since yesterday, it complains about the certificate being expired.

I checked the certificates where I expect them to be (/etc/yunohost/certs/domain.tld/crt.pem, etc/letsencrypt/fullchain.pem), and they’re fine (won’t expire before december).
I used an online checker and it reported all was fine as well.

No other app is complaining, so I assumed the app was at fault. I cleared the cache: same error, I deleted all data and cache and reconfigure the server from 0: same error! It complains about the certificate having expired.

I could believe SMS Backup + has a bug, but a bug with an expired hardcoded certificate sounds unlikely.

Am I missing something?


Answering myself since it is now fixed:

I restarted Dovecot… and that was it!
My guess would be, since I’ve not done so for a long time, that Dovecot somewhat keeps the certificates in a cache and does not automatically renew it?

1 Like