[Galette] Membership management towards non profit organizations


I’ve package Galette for Yunohost, if someone wants to test and give me feedbacks you are welcome.

Sources : GitHub - YunoHost-Apps/galette_ynh: Galette package for YunoHost


Galette is a membership management web application towards non profit organizations, e.g. to manage and have reminders for subscription fees.

Official website : http://galette.eu/

  • Calculate contributions deadlines
  • Members mailings
  • Members cards

What the package does

As of now I didn’t attempt to interface with the Yunohost/LDAP users, the goal being mainly to provide a trivial install of the app.


sudo yunohost app install https://github.com/alexAubin/galette_ynh

Thanks !

You should put an upgrade script (even if it is empty).


thanks a lot for your feedback, I added the empty upgrade script !

Hello, great news ! the installation works but end up with … file not found (redirecting to galette/install/index.php )


thanks for testing the installation ! However I cannot reproduce the issue. Can you tell me which kind of machine did you test it on ? On my side, I tested it on a virtualbox using command-line installation. I also noticed during all my experience with Yunohost that it’s good to have domainname.tld in your /etc/hosts as it solves many issue, and in particular it was needed for my tests. It this an issue ?



hello, i tested it on a vps provided from the french hosting company ovh. Installed last week on top of a fresh debian 8.0. the domain name is hosted on .nohost.me.
Do you want me to try to add the and unsintall and reinsatll the galette ?

Yes please :). Also if you can have some error log that would be awesome. I disabled the automatic rm of the install folder on the repo. In case the install fails because of a missing dependency (it shouldn’t, but maybe our setups are not exactly the same), you should be able to access domainname.tld/galette/install and see that one is missing on the first page.

Thanks !

Tried to reinstall (after adding domainname)

end up with an error

Traceback (most recent call last):
File “initialConf.py”, line 20, in
br.open( “http://”+path+"/install/installer.php" )
File “/usr/local/lib/python2.7/dist-packages/mechanize/_mechanize.py”, line 203, in open
return self._mech_open(url, data, timeout=timeout)
File “/usr/local/lib/python2.7/dist-packages/mechanize/_mechanize.py”, line 230, in _mech_open
response = UserAgentBase.open(self, request, data)
File “/usr/local/lib/python2.7/dist-packages/mechanize/_opener.py”, line 204, in open
response = meth(req, response)
File “/usr/local/lib/python2.7/dist-packages/mechanize/_urllib2_fork.py”, line 457, in http_response
’http’, request, response, code, msg, hdrs)
File “/usr/local/lib/python2.7/dist-packages/mechanize/_opener.py”, line 221, in error
result = apply(self._call_chain, args)
File “/usr/local/lib/python2.7/dist-packages/mechanize/_urllib2_fork.py”, line 332, in _call_chain
result = func(*args)
File “/usr/local/lib/python2.7/dist-packages/mechanize/_urllib2_fork.py”, line 571, in http_error_302
return self.parent.open(new)
File “/usr/local/lib/python2.7/dist-packages/mechanize/_mechanize.py”, line 203, in open
return self._mech_open(url, data, timeout=timeout)
File “/usr/local/lib/python2.7/dist-packages/mechanize/_mechanize.py”, line 230, in _mech_open
response = UserAgentBase.open(self, request, data)
File “/usr/local/lib/python2.7/dist-packages/mechanize/_opener.py”, line 193, in open
response = urlopen(self, req, data)
File “/usr/local/lib/python2.7/dist-packages/mechanize/_urllib2_fork.py”, line 344, in _open
’_open’, req)
File “/usr/local/lib/python2.7/dist-packages/mechanize/_urllib2_fork.py”, line 332, in _call_chain
result = func(*args)
File “/usr/local/lib/python2.7/dist-packages/mechanize/_urllib2_fork.py”, line 1170, in https_open
return self.do_open(conn_factory, req)
File “/usr/local/lib/python2.7/dist-packages/mechanize/_urllib2_fork.py”, line 1118, in do_open
raise URLError(err)

After a reboot i end up with the regular galette installation (asking for mysql DB and so )


thanks for the feedback. So probably it seems like the script can’t open http://"+path+"/install/installer.php for some reason… Did you block maybe http and only allow https ? Did you use any particular settings in the conf maybe, like changing the path to which galette is installed and forgot a / at the beginning ?

No, no major chnages (even the path was the default one => /galette).
Is se install supposed to set up the database and everything ? leaving a running app ?

Yep, it should. The python script is supposed to browse the install page and fill the forms like a human would do, then if you go to your.domain/galette it should just show a login form where you can use the admin login/password. But for some reason it fails opening the page, as you can see :s …

I tried it on one of my production server and it works, so I don’t have much ideas :s.

Can you try to run this small python script ?

import re 
import sys
from mechanize import Browser
br = Browser()

# Ignore robots.txt
br.set_handle_robots( False )

# Set user agent as Firefox
br.addheaders = [('User-agent', 'Firefox')]
# Retrieve the instlation page
br.open( "http://yourDomain.name )

by copying this on your server to a file like script.py, changing the last line with your actual domain name and running python script.py ?

i ran th script but , i’m still on the database installation screen wen returning on the http://domain/galette


sorry for not being specific enough - I was interested if by running this script you get an error message or not :). If not, this means that probably my “path” variable in the install script is not correctly constructed. If it does, then there’s something preventing the access to your http server at this url from localhost. Did you see an error message ?

No, no error messages running the script (from the server in comman line)


I’ve install galette version with PostgreSQL.
I’ve participate to a PR in order to upgrade version

If i do a fresh install with version or there is no problem and i can use Galette immediately.

After upgrade it from to, i have to go to https://domain/path_to_galette/installer.php in order to choose “update” and re-validated some field but i am stumbling on the data base password.

I’ve certainly missed something … so if someone could help me to retrieve where i can find the data base password it would be great.

Edit : found it in the php config file of the app

sudo su
cat /var/www/galette/galette/config/config.inc.php

Thanks in advance,