Galene Turn Server Not Working

:uk:/:us: Message template (english)

My YunoHost server

Hardware: Old laptop or computer: Lenovo Think Server

YunoHost version: 11.2.10 (stable).

I have access to my server : Through SSH and webadmin

Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

If your request is related to an app, specify its name and version: Galene 0.8.0~ynh2

Description of my issue

Galene Turn server not working. When I log into a group, I see only me. When others in the group log in, they only see themselves. No audio at all. We can text each other. After a period of time each group member is disconnected. When the members of the group log in, again, you are logged in more than once. Only text works.

NB: you can use to share logs and error messages. You can also directly include error messages using backticks like this :

Here are the logs when starting Galene:
Feb 13 13:11:44 systemd[1]: Started Galène: videoconferencing server.
Feb 13 13:11:44 galene[2378]: 2024/02/13 13:11:44 Starting built-in TURN server on
Feb 13 13:13:53 galene[2378]: 2024/02/13 13:13:53 Relay test failed: timeout
Feb 13 13:13:53 galene[2378]: 2024/02/13 13:13:53 Perhaps you didn't configure a TURN server?
Feb 13 14:14:14 galene[2378]: 2024/02/13 14:14:14 client: websocket: close 1006 (abnormal closure): unexpected EOF
Feb 13 14:14:39 galene[2378]: 2024/02/13 14:14:39 Replace: file does not exist
Feb 13 14:16:50 galene[2378]: 2024/02/13 14:16:50 client: client is dead
Feb 13 14:18:43 galene[2378]: 2024/02/13 14:18:43 client: client is dead

Note: Galene is using port 1195. I noticed port 1194 begin blocked by Charter-Spectrum. I will be calling to get port 1194 opened.

Galene uses port 1194 because it is the OpenVPN port, which is open in many university networks. If you need to use a different port, please use the -turn option on Galene’s command line:

galene -turn ":1234"

Please note the colon, it is required.

Hey jch,
I don’t start Galene from the command line but rather from Yunohost. The /etc/systemd/system/galene.service file has no colon. Do I add this to the URL?

Just add -turn :1234 at the end of the ExecStart line.

(I believe that you might need to redo the change every time you upgrade Galene. I’ll make it easier to configure in the next version.)

Here is the ExecStart line:

ExecStart=/var/www/galene/live/galene -http “” -insecure -turn -udp-range 49152-65535 -groups /home/ -recordings /home/ -data /var/www/galene/live/data/ -turn :1195

Ah, sorry, I’ve missed that: you’ve already switched to port 1195. So actually your issue is this:

Relay test failed: timeout
Perhaps you didn’t configure a TURN server?

Please connect to Galene, and type /relay-test in the chatbox. Two cases:

  1. If Galene says Relay test failed, then the TURN port is not accessible. Please reconfigure your router to forward the TURN port.

  2. If Galene says Relay test successful, then the TURN port is accessible, but your NAT doesn’t support hairpinning. In that case, please check your router’s configuration to see whether there’s an option to enable hairpinning. (But I’m not optimistic, routers that support hairpinning usually enable it by default.)

I will check. But the weird thing is Galene was working fine just two weeks ago. This past weekend it stopped.

The relay test failed (knew it would). My router is set to port forwarding for 1194 and 1195.

The relay test failed (knew it would). My router is set to port forwarding for 1194 and 1195.

From inside the NAT or from the outside?

I am inside the NAT. Always have been. It was working then just stopped last weekend.

btw, the turn server was not starting on 1195 either.

What happens if you do it from outside the NAT? (Feel free to send me a token (/invite in the chat) by private message, and I’ll test it for you.)


When outside the NAT (connecting to Galene) it fails as well. The Turn server is not starting.

Your log says Starting built-in TURN server on You may check whether it’s started by doing netstat -apn, see if somebody’s listening on port 1195.

Nobody is listening on Port 1195

I’m sorry, I’m afraid I’m at a loss here.

I can’t get Galene to try Port 1195.

Can I install Galene at Github? I did that with Chitchatter.

Hi @ralphshinevar , I’m struggling with the Galene Turn server too.
I have not got the /relay-test command to work with the built in or external server yet.

…just wanted you to know :sweat_smile:

edit: However, the connection from inside LAN to the outside seems to work Ok here.