Funkwhale can't install - database not removed from failed attempt?

My YunoHost server

**Hardware: physical
YunoHost version: 4.0.8
**I have access to my server full

Debian 10

Description of my issue

I see this in the /var/log/postgresql/postgresql-11-main.log file: I don’t know how to log in to access or delete the DB if it’s there.

2020-09-20 16:33:30.212 EDT [1735] postgres@postgres ERROR: database “funkwhale” already exists
2020-09-20 16:33:30.212 EDT [1735] postgres@postgres STATEMENT: CREATE DATABASE funkwhale;
2020-09-20 16:34:21.243 EDT [4778] funkwhale@funkwhale FATAL: password authentication failed for user “funkwhale”
2020-09-20 16:34:21.243 EDT [4778] funkwhale@funkwhale DETAIL: Password does not match for user “funkwhale”.

Funkwhale failed to get removed after a failed installation - here are those logs:

Have you tried to install a second time ? It could do the job.

Alternatively, you can connect to db like this

sudo -u postgres psql

I did try a second time. I’m totally new to Debian and postgresql so I’m not sure how to run that command. I get ‘command not found’ when I run from bash.

Also, tried adding two other apps and they are also failing with errors related to nginx.

Looking at the Diagnostics, I see this error:

Configuration is broken for service nginx! Ignore Details

  • nginx: [emerg] open() “/var/www/funkwhale/code/deploy/funkwhale_proxy.conf” failed (2: No such file or directory) in /etc/nginx/conf.d/
  • nginx: configuration file /etc/nginx/nginx.conf test failed

Here is another log file which I think may be related, from an attempt to add in pgadmin:

Hm, looks like it’s all apps. Tried to upgrade Nextcloud from System Update and it also failed - and seems to have removed Nextcloud from my apps list altogether.

Here are the logs from nginx:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.