FreshRss with EasyRSS

en

#1

I know this is a 3 party apps,but i never get working the TTRSS with TTRSS-Reader from android with yunohost,always problems synchronizing the feeds in android…
FreshRss works great in any browser platform,and it seems we have another option EasyRSS for android that seems working with FreshRSS,but not with yunohost sso.
Anybody here use any reader for android syncronizing with yunohost?
It will be good have a solution to offline feeds using yunohost and the api.


#2

Hi, I am synchronizing my TTRSS with the officiel TTRSS android app (found in F-Droid). My settings:
URL: Yunoost url to ttrss + username + password.
HTTP-authentication: disable
SSL: Accept all certificates, trust all hosts


[Resolu] Synchronisation freshrss ou de ttrss avec une application cliente
#3

thks, @scith,that configuration is what i use,i have the android app,but ,after a while when synchronizing,says message gateway time-out,i see all categories feeds in th app,but not pushing the feeds,maybe i have too many feeds,i did a test and if i have only 10 feeds in the opml file,works good,i checked errors in ttrss and delete all feeds with errors,buts its the same with my opml…in the browser works good ,the ttrss and the freshrss.
do you know any free feed validation service that check all the errors in a opml file?


#4

In your Yunohost TTRSS preferences, have you checked “Enable API Access”?
Also in the Android App I have checked “lazy server”.

I check 110 feeds daily without any issue.

Cheers


#5

hey @scith,
yes i have api open and the lazy server.
i have many more than you in feeds in my opml.
i think maybe have feeds with some errors that the api cannot handle.the ttrss or the freshrss in the browser no problem and i always delete in ttrss feeds with errors in preferences or in freshrss using statistics idle feeds.
the freshrss works great,but not a funcional api for android.
if i have few feeds works without problems,can fetch them all ok in android.
i need to find what feeds is causing this problem,and not easy with many urls.
i only see services that i need to put urls one by one in th net for feed validation.
maybe cutting my opml to less feeds will resolve my problem,but i dont know if i will choose the wrong ones…i will see…thks


#6

|ω.)つ OPML validators

That second one looks pretty easy to use, just pass it the url to an OPML file. Though it’s kinda old, and still in beta, and I haven’t tried it myself…


#7

thks @tiemay but not worked the link.
i try to edit the opml file and split categories to less feeds,not worked, change the ttrss -reader app for version 1.84.1 from f-droid seems working better than the version i have installed before.
the feeds load and after a while they disappear in categories,and become in a grey color,the total number of all articles dont match with the browser,sometimes fetch all the category but they disappear without doing nothing.
i still think this is a problem with the api dealing with some urls,maybe if try delete more categories…or just find what urls the api dont deal well i can make this usable.
better stay with the browser,the app for android need more code work.


#8

Do you have any issues with a different rss feed reader like quiterss?

This script might help you find problematic feeds:

#!/bin/bash

##
# Required packages: xml2 wget subversion python 2.2 or later
##

# Set this to the location of your opml file.
opmlFile="./my.opml"

# Make sure feed validator is downloaded and ready.
if [[ ! -e ./feedvalidator-code/ ]]; then
  echo "[info] downloading FeedValidator..."
  svn checkout svn://svn.code.sf.net/p/feedvalidator/code/trunk feedvalidator-code
fi

# bash alone isn't good at parsing xml, so lets format it in a way bash can better manage.
echo "[info] parsing opml file..."
xml2 < "${opmlFile}" > "${opmlFile}.flat"
urls=( $(grep '@xmlUrl=' "${opmlFile}.flat" | cut -d '=' -f2- ) )

echo "[info] making sure RSS feed URLs exist..."
for url in "${urls[@]}"; do

  echo "[checking] ${url}"
  # wget -O - -q downloads the rss feed to stdout, then >/dev/null sends stdout to Tartarus.
  wget -O - -q "${url}" >/dev/null

  if [[ ! ${?} == 0 ]]; then
    echo "ERROR: there was a problem downloading: ${url}"

    # Remove broken urls from list so they don't try to get validated below.
    urls=( "${urls[@]/${url}}" )
  fi
done

echo "[info] validating existing RSS feed URLs..."
for url in ${urls[@]}; do
  python ./feedvalidator-code/feedvalidator/src/demo.py "${url}"
done


You’ll need xml2, wget, subversion, and python 2.2 or later installed for it to work. It uses the same RSS validator as on w3c, though unfortunately, the local version seems to only spit out the warnings and errors, and doesn’t summarize them like the web application does. This page has a list of the errors and warnings the validator may throw.


#9

Look nice quiterss,but not have api for android.
i think i tried some months ago and never get this feedvalidator working,that you are talking about.
But maybe i will try tomorrow again, in other machine.
thanks for your answer,Tiemay


#10

What I meant to ask was, if you import the opml file to quiterss, does quiterss give any errors?

Where you able to run the script I posted?


#11

hey tiemay,
i dont see why i need to install another feed reader,im using yunohost,the app need to be prepared to work here,and the quiterss is not build for use here,you can check here the example how to build a app for yunohost: https://github.com/Kloadut/example_ynh
do you use yunohost? is not dificult make a app if you want! see u:)


#12

I’m just wondering if your opml file works ok with a different feed reader, because if it does, then the issue probably isn’t the opml file, or your feeds.


#13

yes works in every feed reader.


#14

Easyrss app for android is working with yunohost.

Need to configure password for api in freshrss “Profile” menu
(e.g., for mobile apps)

The url for easy rss is :
https://yourdomain/rss/api/greader.php

.


#15

for me it’s still not work, I configure a password for api, I have activate the api, but connection still failed from easy rss (I install it from Fdroid).


#16

sorry cant help you more,maybe you are not putting the correct url,here works im using from fdroid too.
here the thread https://github.com/plopoyop/freshrss_ynh/issues/7


#18

@cabbes I just found out what was wrong:
Edit this file: /etc/nginx/conf.d/yourdomain.d/freshrss.conf

And under PATH_INFO add this line:
fastcgi_param PATH_TRANSLATED $document_root$fastcgi_path_info;

It’s working for me


#19

@thomas mine nginx freshrss.conf ,dont have the line,and works with no problems,can you tell me ,what advantages i will have adding that line?


#20

I don’t know what are the advantages of this line precisely. FreshRSS wasn’t working with EasyRSS and I found that line in the issues on the FreshRSS Github and now it’s working That’s all :smile:


#21

uhmm…glad that is working for you now,you put me here trying to find what´s for that line…we are always learning in life,well for me, if works don’t mess with it, i move ahead and keep going:)