Fresh install, domain not working

Hi all,

I’ve just completed a fresh install of Yunohost on Debian Jessie, everything seemed to complete without errors and I can access the server over local ip.

I registered a domain during install, but when I try to goto the domain I get a server not found error. I’ve installed Yunohost before and the domain has always worked fine. I waited over night to see if DNS would propogate but the page still does not load.

Thanks for any help

Edit: I have ports 80 and 443 forwarded and I can connect to the server by its public ip

I have made a fresh install of jessie + yunohost using ‘’ instead of ‘’ and I’m still seeing the same error. the domains are;

edit: I get the following error when I run ‘yunohost dyndns update’

You might encounter an issue. This two domains are well registered but lead to nowhere.

Is there a way I can make it work? ive tried just about all i can think of

@JordyV could you try yunohost dyndns update -d --verbose please ?
If your domain is really, because I saw both and on our dyndns server. Note that you can only have one dyndns per installation.

Yes, the domain is, when it didn’t work originally i also tried
The only domain attached to yunohost is the one.

Here are the results from that command

Wow, YunoHost do not handle IPv6?
Shit software :smile:
How do you want to do self-hosting with IPv4?

@Moul : thanks for your support, it really helps us moving forward.

@JordyV : is your server have an IPv4 connectivity, or IPv6 only ?

@JordyV also, can you tell us what’s in the /etc/yunohost/dyndns folder ?

I investigate this error, and it seems that there is no dnssec key on your server; You can force a key generation by doing :

cd /etc/yunohost/dyndns
dnssec-keygen -a hmac-md5 -b 128 -r /dev/urandom -n USER
chmod 600 /etc/yunohost/dyndns/*.key /etc/yunohost/dyndns/*.private

and then paste us the output of yunohost dyndns update -d --debug.

Here are the results of ‘ls -a’ in that directory, if I should check another way let me know

plumbus@plumbus:~$ cd /etc/yunohost/dyndns
plumbus@plumbus:/etc/yunohost/dyndns$ ls -a
.  ..  zone

I ran the code above as root and I got the following error

root@plumbus:/etc/yunohost/dyndns# yunohost dyndns update -d --debug
55   DEBUG loading actions map namespace 'yunohost'
59   DEBUG extra parameter classes loaded: ['ask', 'password', 'required', 'pattern']
60   DEBUG initializing base actions map parser for cli
61   DEBUG registering new callback action 'yunohost.utils.packages.ynh_packages_version' to [
'-v', '--version']
5124 ERROR An instance is already running

Thanks again for your help

I reboot the server and rand the above dyndns command again, here is the result

root@plumbus:/etc/yunohost/dyndns# yunohost dyndns update -d --debug
47   DEBUG loading actions map namespace 'yunohost'
52   DEBUG extra parameter classes loaded: ['ask', 'password', 'required', 'pattern']
52   DEBUG initializing base actions map parser for cli
53   DEBUG registering new callback action 'yunohost.utils.packages.ynh_packages_version' to [
'-v', '--version']
111  DEBUG lock has been acquired
1057 INFO processing action [1545.1]: yunohost.dyndns.update with args={'domain': 'plumbus.noh', 'key': None, 'dyn_host': '', 'ipv4': None, 'ipv6': None}
4836 INFO IPv6 connectivity is not available
Outgoing update query:
;; ->>HEADER<<- opcode: UPDATE, status: NOERROR, id:      0
;; flags:; ZONE: 0, PREREQ: 0, UPDATE: 0, ADDITIONAL: 0
;                       IN      SOA

;; UPDATE SECTION:        0       ANY     A        0       ANY     AAAA        0       ANY     MX        0       ANY     TXT 0       ANY     A 0       ANY     AAAA    0       ANY     A    0       ANY     AAAA   0       ANY     A   0       ANY     AAAA 0 ANY SRV 0 ANY SRV        1800    IN      A        14400   IN      MX      5        14400   IN      TXT     "v=spf1 a mx -all" 1800    IN      A    1800    IN      A   1800    IN      A 14400 IN SRV 0 5 5222 14400 IN SRV 0 5 5269

; TSIG error with server: tsig indicates error
update failed: NOTAUTH(BADSIG)
5205 DEBUG action [1545.1] ended after 4.147s
5205 DEBUG lock has been released
5205 ERROR Unable to update IP address on DynDNS

Hi there,

I’ve been having trouble with my Yunohost installation. Everything is fine except that the domain (ending in does not always lead to my server. The ports check site shows me that the ports are closed for the domain, even though they are open in my router. That happens on an off and on basis with no real indication of what the error is.

Could it be an issue that I have the same domain name open with a ending from a very old install I don’t use anymore? Could that be an interfering problem?

The Domain is now deleted and my server has a lot more uptime, but it is still not reachable 24/7. Is there a way to find out what the problem is? Maybe you could tell me if there is a log of some sort that keeps track of the DNS availability or something.