Freebox - let's encrypt ne fonctionne plus

Hello,

impossible d’avoir un let’s encrypt qui fonctionne voici l’erreur :

2020-02-07 20:44:54,306: DEBUG - ++ ‘[’ -r /usr/share/yunohost/helpers.d/user ‘]’
2020-02-07 20:44:54,307: DEBUG - ++ . /usr/share/yunohost/helpers.d/user
2020-02-07 20:44:54,308: DEBUG - ++ for helper in $(run-parts --list /usr/share/yunohost/helpers.d 2>/dev/null)
2020-02-07 20:44:54,314: DEBUG - ++ ‘[’ -r /usr/share/yunohost/helpers.d/utils ‘]’
2020-02-07 20:44:54,315: DEBUG - ++ . /usr/share/yunohost/helpers.d/utils
2020-02-07 20:44:54,316: DEBUG - + FORCE=0
2020-02-07 20:44:54,316: DEBUG - + DRY_RUN=0
2020-02-07 20:44:54,317: DEBUG - + case “$1” in
2020-02-07 20:44:54,318: DEBUG - + do_post_regen /etc/resolv.dnsmasq.conf
2020-02-07 20:44:54,321: DEBUG - + regen_conf_files=/etc/resolv.dnsmasq.conf
2020-02-07 20:44:54,323: DEBUG - + [[ -z /etc/resolv.dnsmasq.conf ]]
2020-02-07 20:44:54,324: DEBUG - + sudo service dnsmasq restart
2020-02-07 20:44:55,931: DEBUG - + exit 0
2020-02-07 20:44:55,953: DEBUG - Exécution de la commande ‘sh -c YNH_INTERFACE=api YNH_CWD=/usr/share/yunohost/hooks/conf_regen YNH_STDINFO=/tmp/tmppMqdHK/stdinfo YNH_STDRETURN=/tmp/tmpQDP5yS/stdreturn BASH_XTRACEFD=7 /bin/bash -x “./50-dnsmasq_pihole” post 0 0 ‘’ 7>&1’ …
2020-02-07 20:44:55,955: DEBUG - About to run the command ‘[‘sh’, ‘-c’, ‘YNH_INTERFACE=api YNH_CWD=/usr/share/yunohost/hooks/conf_regen YNH_STDINFO=/tmp/tmppMqdHK/stdinfo YNH_STDRETURN=/tmp/tmpQDP5yS/stdreturn BASH_XTRACEFD=7 /bin/bash -x “./50-dnsmasq_pihole” post 0 0 ‘’ 7>&1’]’
2020-02-07 20:44:56,122: DEBUG - + force=0
2020-02-07 20:44:56,125: DEBUG - + dryrun=0
2020-02-07 20:44:56,126: DEBUG - + pending_conf=
2020-02-07 20:44:56,126: DEBUG - + temp_dir=/tmp/pi-hole.bck
2020-02-07 20:44:56,127: DEBUG - + case “$1” in
2020-02-07 20:44:56,128: DEBUG - + do_post_regen
2020-02-07 20:44:56,129: DEBUG - + cp -a /tmp/pi-hole.bck/01-pihole.conf /etc/dnsmasq.d/
2020-02-07 20:44:56,130: DEBUG - + test -e /tmp/pi-hole.bck/02-pihole-dhcp.conf
2020-02-07 20:44:56,130: DEBUG - + test -e /tmp/pi-hole.bck/03-pihole-wildcard.conf
2020-02-07 20:44:56,131: DEBUG - + test -n /tmp/pi-hole.bck
2020-02-07 20:44:56,132: DEBUG - + rm -r /tmp/pi-hole.bck
2020-02-07 20:44:56,133: DEBUG - + sed --in-place ‘s/^cache-size=/#pihole# cache-size=/g’ /etc/dnsmasq.conf
2020-02-07 20:44:56,134: DEBUG - + systemctl reload dnsmasq
2020-02-07 20:44:56,135: DEBUG - + exit 0
2020-02-07 20:44:56,152: DEBUG - Journal historisé complet de cette opération : ’ Régénérer les configurations du système ‘dnsmasq’
2020-02-07 20:44:56,162: DEBUG - Prepare key and certificate signing request (CSR) for domaine.fr
2020-02-07 20:45:03,596: DEBUG - Saving to /tmp/acme-challenge-private/domaine.fr.csr.
2020-02-07 20:45:03,681: DEBUG - Now using ACME Tiny to sign the certificate…
2020-02-07 20:45:03,682: INFO - Parsing account key…
2020-02-07 20:45:03,717: INFO - Parsing CSR…
2020-02-07 20:45:03,751: INFO - Found domains: domaine.fr
2020-02-07 20:45:03,753: INFO - Getting directory…
2020-02-07 20:45:04,757: INFO - Directory found!
2020-02-07 20:45:04,760: INFO - Registering account…
2020-02-07 20:45:12,895: INFO - Already registered!
2020-02-07 20:45:12,899: INFO - Creating new order…
2020-02-07 20:45:20,310: INFO - Order created!
2020-02-07 20:45:21,389: INFO - Verifying domaine.fr
2020-02-07 20:45:36,755: ERROR - Challenge did not pass for domaine.fr: {u’status’: u’invalid’, u’challenges’: [{u’status’: u’invalid’, u’validationRecord’: [{u’url’: u’http://domaine.fr/.well-known/acme-challenge/3KaIs2fSI1PIv0AL0e1Pco6LZfmb7JiazziUGsnmD9I’, u’hostname’: u’domaine.fr’, u’addressUsed’: u’XXX.XXX.XXX.XXX’, u’port’: u’80’, u’addressesResolved’: [u’XXX.XXX.XXX.XXX’]}], u’url’: u’https://acme-v02.api.letsencrypt.org/acme/chall-v3/2696304361/i815FQ’, u’token’: u’3KaIs2fSI1PIv0AL0e1Pco6LZfmb7JiazziUGsnmD9I’, u’error’: {u’status’: 400, u’type’: u’urn:ietf:params:acme:error:connection’, u’detail’: u’Fetching http://domaine.fr/.well-known/acme-challenge/3KaIs2fSI1PIv0AL0e1Pco6LZfmb7JiazziUGsnmD9I: Timeout during connect (likely firewall problem)’}, u’type’: u’http-01’}], u’identifier’: {u’type’: u’dns’, u’value’: u’domaine.fr’}, u’expires’: u’2020-02-14T20:45:20Z’}
2020-02-07 20:45:37,480: WARNING - Debug information:

  • domain ip from DNS XXX.XXX.XXX.XXX
  • domain ip from local DNS XXX.XXX.XXX.XXX
  • public ip of the server XXX.XXX.XXX.XXX

2020-02-07 20:45:37,483: ERROR - Certificate renewing for domaine.fr failed !

qu’en pensez vous svp ?

hello
le port 80 est-il bien ouvert sur ta box et est-il bien redirigé vers ton serveur yunohost?

1 Like

Bonjour, oui le port 80 443 et tous sont ouvert, je pense que le probléme viens de la box FREEE
car je viens de changer d’adresse ip public

car free propose mainteneant des box 4G et ADSL

du coup suivant si je suis en 4G ou en ADSL j’ai plus la meme IP et du coup çàa me fout le bordel sur mon yunohsot
fait chié
je sais pas quoi faire

Bonjour,
Je crois aussi que désormais Free partage les IPv4 entre plusieurs abonnés. Pour la 4G je ne sais pas, mais si tu n’as pas de IP full stack ça risque de bien dysfonctionner !

1 Like

Je confirme, j’ai appris çà il y a peu.
La soluce est soit de passer par ddclient, soit d’utiliser le DynDNS de Free

1 Like

Et encore. Apparemment sur les IP partagées il n’y a pas moyen d’ouvrir les bons ports.

1 Like

Comme le dit @anonyme24 les IP partagées c’est différent des IP dynamiques.

1 Like

Là, je ne suis temporairement pas sous Box Free. Que dit leur help desk sur DynDNS ?

1 Like

Si c’est un problème d’IP patagée, tu peux demander une IP full-stack sur ton compte client free. Ça s’est très bien fait pour moi (délai de quelques jours max).

1 Like

Tout dépend des ports qui sont attribués, si ce sont les 1er, ça fonctionnera quand même et il est possible de les ouvrir (testé).

1 Like

Je suis moi aussi chez Free.
Il y a quelques semaines/mois je n’arrivais plus à me connecter à mon serveur. En fouillant, j’ai découvert que je n’avais plus la même adresse. Mais ça se fixe en (re)demandant une adresse statique.

Dans l’interface de gestion, y’a un bouton pour demander une adresse IP statique. En quelques heures tu l’obtiens. Il faut ensuite mettre à jour ton DNS.

En espérant que ça aide…

1 Like

Je suis également passé sur une Ip fixe mais j’ai perdu au passage le reverse DNS

1 Like

Je pense que tu as bien identifié le problème.
La bascule adsl/4g te fais changer d’IP.
Est-ce que tu sais si l’ip 4G est fixe elle aussi ?

Chez Free l’ip sur une ligne internet est toujours fixe, je ne sais pas si c’est le cas sur leur agrégation 4G aussi.

Sinon aucun problème pour moi après avoir demandé une ip full stack.

1 Like

oui elle est fixe aussi, mais comme tu est obligé d’activer la bascule adsl/4g tu peux pas utiliser uniquement la 4G ou l’adsl, du coup j’ai désactiver la 4G, j’ai débit minable d’adsl, la fibre qui n’arriveras chez moi, c’est rageant !

J’ai même contacter le conseille général de mon patlin qui me dise depuis 3 ans, oui la fibre seras installé en fait d’"année dans votre quartier, tu parle ça fait des années, que j’attends, ça m’énerve !!!

du coup je subis en ADSL, et je me suis pris un abo 4G free 100 mega, quand j’ai besoin de faire du gros download.

à la fibre …

bon mon certificat refonctionne mais mails semble aussi refonctionné, mais du coup je ne sais pas depuis combien de temps mon installation yunohost était foireuse :’(