Forgejo packaging V2 : test

hi,
The testing branch of forgejo app is now in V2 packaging format (thanks a lot @ericg for your work)

Can someone have some time to test it before I merge it to master branch ?

Thanks.

1 Like

I installed the testing branch and created a new repository. No problems so far.

Do you want me something else to test?

Thank you @snm
I’m interested in testing the upgrade process. Any volunteer ?

Sorry for the late reply. I’ll try to test in on the weekend and them report back.

Hello,
I will try. I have already a Gitea instance, but I want migrate from Gitea to Forgejo. I want try install it, migrate the repositories, and test the testing branch…

1 Like

First install, I couldn’t see admin user connecting to forgejo. I found I have the same issue with Gitea… Do you know how we can edit this ?? I see the permissions in the webadmin, but it didn’t works…

What do you mean with “connecting to Forgejo”? Do you mean using it with git? Or login with the browser?

logging with a browser, I discover I haven’t the ‘administration of the site’ visible

Did you login with your YunoHost instance first before opening the Forgejo app?

Yes, connected with the Yunohost LDAP

I discover the same issue exist for Gitea, I have few users, but the admin settings are forbidden…

Oh, you mean the “Site Administration” is missing in the menu on the top right for the admin user? It’s the same here, even with the current “stable” (non testing) version of Forgejo.

It works with Gitea here, though.

Edit: It’s also strange that on the YunoHost admin page of Forgejo (<mydomain>/yunohost/admin/#/apps/forgejo/operations) the admin user is shown with name “admin”. There is no user named “admin” on my system, though, and I selected another name as admin user when installing Forgejo. Changing the admin user to the one selected during installation doesn’t solve the problem (There is still no “Site Administration” page on Forgejo).

On another instance of yunohost we have a Gitea, but the admin settings exist, we could also have few admin users…

it is really strange… I have install forgejo with another admin user than Gitea, perhaps it made mistakes… I have try moving permissions for forgejo(admin) in the webadmin, put this permissions forgejo(admin) disappear !! But it is strange because my user admin for Gitea does not have access of admin settings.
I remove forgejo first and try again…

Is it possible found where edit the admin settings somewhere ?

if I try yunohost user permission list
I have a user permissions admin for gitea and for forgeo

  forgejo.admin: 
    allowed: myuser
  gitea.admin: 
    allowed: myuser

but I can’t go to admin settings in both apps

Looks the same here. I can go to the admin settings of Gitea but not to the admin settings of Forgejo. Admin user is the same for both.

Ok, but you can access to settings admin in Gitea…
I think I have broken something trying moving to give the permission gitea(admin) to the group admins… Now I put it back to the user used with the install process, but still not working…
I have removed and reinstall forgejo with the same user admin also…

Sorry, this had nothing to do with the upgrade process so far. But I tried the upgrade, too.

At first, it seemed to work. No problems shown during the upgrade with

sudo yunohost app upgrade forgejo -u https://github.com/YunoHost-Apps/forgejo_ynh/tree/testing --debug

But when I tried a git push I got a permission denied (publickey). The SSH key is still the same as before the upgrade and it did work before. After downgrading (restoring the backup) it worked again.

(I have to go now, will probably be back tomorrow).

I have tried something like sudo -u gitea /opt/gitea/gitea admin auth update-ldap --name myuser --id 1 --admin-filter IsAdmin

but it doesn’t work…

I found in phpmyadmin a table login_source with this

{"Name":"Yunohost LDAP","Host":"localhost","Port":389,"SecurityProtocol":0,"SkipVerify":false,"BindDN":"","BindPasswordEncrypt":"xxxxxxxxxxxxxxxxxxxxxxxxxxxx","BindPassword":"","UserBase":"ou=users,dc=yunohost,dc=org","UserDN":"","AttributeUsername":"","AttributeName":"givenName","AttributeSurname":"sn","AttributeMail":"mail","AttributesInBind":false,"AttributeSSHPublicKey":"","AttributeAvatar":"","SearchPageSize":0,"Filter":"(\u0026(uid=%s)(objectClass=posixAccount)(permission=cn=gitea.main,ou=permission,dc=yunohost,dc=org))","AdminFilter":"IsAdmin","RestrictedFilter":"","Enabled":true,"AllowDeactivateAll":false,"GroupsEnabled":false,"GroupDN":"","GroupFilter":"","GroupMemberUID":"","GroupTeamMap":"","GroupTeamMapRemoval":false,"UserUID":""}

also I try push a repo with logos and images from Gitea, but I can’t see the images…
Well, I found the same issue is on Gitea or Forgejo, if I am connected with my user by Yunohost LDAP, the images in the repo seems broken, with an error Le cookie « macaron_flash » a été rejeté car il a déjà expiré. similar at this issue: Browser warnings related to `macaron_flash` cookie · Issue #24062 · go-gitea/gitea · GitHub

If I sign out and visit the repo, then I can see the images… It seems related with the LDAP and the sso…

Very strange also, if I sign out from the yunohost portal and come back to the gitea site or forgejo, it is similar, I am still connected with my user (cookies still here and could see private repos) until I haven’t sign out, I also could see the images !