Forbidden Error Uploading to Multimedia Directory in Nextcloud


My YunoHost server

Hardware: Librem Mini 1 (old computer)
YunoHost version: 11.0.11
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hey Folks,

Just installed Yunohost, Nextcloud & Jellyfin today with default settings across the board. Using both the Nextcloud web interface and Nextcloud Desktop on Windows I am unable to upload files to either ‘Nextcloud\Multimedia\Video’ or ‘Nextcloud\Shared multimedia\Video’. Was hoping to use those directories for my Jellyfin Media Library. Below is a screenshot of the error I’m getting:


I even tried to SFTP into the server as ‘admin’ user but it wouldn’t let me upload files that way either.

I have only one created user on my Yunohost server (showing as USER below for privacy reasons), logged into Nextcloud with that user but still can’t add files to my own Multimedia directory. SSH’ed into the server and the permissions show my user as the owner of ‘/home/yunohost.multimedia/USER’ ‘drwxrwxr-x+ 2 USER root 4096 Jan 26 13:47’.

External Storage is enabled in Nextcloud, even added ‘All Users’ in the ‘Available For’ field in Nextcloud. Tried to comb through the forum but couldn’t find a similar issue. Any help I could get would be greatly appreciated.

Edit 1: Saw this error msg in Nextcloud when trying to upload file via the web:

[no app in context] Error: Sabre\DAV\Exception\BadRequest: Expected filesize of 1000000000 bytes but read (from Nextcloud client) and wrote (to Nextcloud storage) 776798208 bytes. Could either be a network problem on the sending side or a problem writing to the storage on the server side. at <<closure>>

Have tried multiple video files from 16MB to 5GB and nothing will upload into those directories. Also can’t upload into the main Nextcloud directory and move the files. Figure its a permissions issue but don’t know where to go from here other than to ask for help. Sorry for the bother.

I think that NextCloud doesn’t like that you put files in its own folders, it required to sync its database to do it properly !?

Anyway, I’ve you tried this, maybe it would help ?

Thanks @GoustiFruit I checked it out the link but am at the point where I think its a permissions issue on my Yunohost install since I can’t add files into it even via SFTP.

Since this is the default setup, I didn’t add the Multimedia directories, they were already in there so wondering what could be wrong on the permissions side.

I updated to the newest version of Yunohost and turns out everything is working fine. Thought I had tried that but here we are. Closing.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.