Flarum : Adding extension with composer dont work

,

Always have errors while trying to instasll extensions. I’m on lastest Flarum and latest Yunohost builds.

@tituspijean

Here the error:

root@3ckm:/var/www/flarum# sudo -u $app php7.3 composer.phar require -W the-turk/flarum-stargazing-theme
Using version ^0.1.1 for the-turk/flarum-stargazing-theme
./composer.json has been updated
Running composer update the-turk/flarum-stargazing-theme --with-all-dependencies
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Root composer.json requires the-turk/flarum-stargazing-theme ^0.1.1 → satisfiable by the-turk/flarum-stargazing-theme[0.1.1].
- the-turk/flarum-stargazing-theme 0.1.1 requires flarum/core ^0.1.0-beta.10 → found flarum/core[v0.1.0-beta.10, …, v0.1.0-beta.16] but it does not match your minimum-stability.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.
root@3ckm:/var/www/flarum#

This plugin/theme is abandoned, outdated, and uncompatible with the current version of Flarum. cf. Stargazing Theme - Flarum Community

1 Like