[Flarum] A lightweight forum

was low memory; I upgraded my VPS and now it works :slight_smile:

1 Like
  • [fr] Est-ce que Flarum peut s’installer lorsqu’on utilise un sous domaine en nohost.me ?
  • [en] Could Flarum be installed on nohost.me domain ?
  • There should be no limitation regarding subdomains, so yes. Please try and report any problem.
  • Il ne devrait pas avoir de limitation sur les sous-domaines, donc oui. Essaie, et rapporte-nous tout problème que tu pourrais rencontrer.

Merci pour ta réponse @tituspijean
J’aimerais bien tester effectivement.
Flarum n’apparaît pas dans la liste des applications fiables, de qualité décente, ou opérationnelles.
Crois-tu que sur une raspberry pi sous YunoHost 3.8.4.9 (stable)., je peux “casser le système” comme l’indique le message d’alerte à l’installation via l’API de Yunohost en admin ?

Ah oui. Actuellement les tests qui vérifient le bon fonctionnement de Flarum échouent à cause de limitations en mémoire sur le serveur de tests. Passe par la ligne de commande et force l’installation. Au pire, l’installation de Flarum plante, mais YNH se charge de supprimer tout ce qu’il faut si ça arrive.

Hello, je suis allé poser ma question sur le discuss.flarum mais personne n’a de réponse (ils ne sont pas très au fait de yunohost) : depuis la dernière mise à jour de Flarum Bazaar a disparu (il sera apparemment remplacé par extiverse mais c’est un peu le bordel pour l’instant on dirait) et toutes mes extensions avec. J’essaie de les réinstaller avec Composer et il me sort :

    - doctrine/cache 1.10.1 requires php ~7.1 || ^8.0 -> your PHP version (7.0.33) does not satisfy that requirement.
    - doctrine/cache 1.10.1 requires php ~7.1 || ^8.0 -> your PHP version (7.0.33) does not satisfy that requirement.
    - Installation request for doctrine/cache (locked at 1.10.1) -> satisfiable by doctrine/cache[1.10.1].

Quelqu’un a une idée ?
(Si besoin dites le moi et je créerai un sujet exprès je veux pas flooder ici)

Bonjour !

Je réalise qu’il y a une remarque que j’ai mise sur GitHub qui n’apparaît pas sur le forum: lors d’une mise à jour de l’app via YunoHost, les extensions sont désinstallées. C’est une limitation que j’ai pour l’instant, tu dois en effet les réinstaller à la main.

Tu ne précises pas quelle est la commande que tu utilises, mais au vu de ton erreur, je supposes que tu n’appelles pas la bonne version de PHP, et pas avec le bon utilisateur:

sudo -u flarum php7.3 composer.phar require fof/upload

Victoire ! Merci beaucoup !
Haha je vois à l’instant que tu m’as grillé de quelques secondes chez le discuss Flarum :smiley:

1 Like

Hi there, for some reason it takes Flarum 2 days to send a e-mail notification. Do you have an idea what the reason could be?

I’m on 0.1.0-beta.13~ynh1
driver in email settings is “mail”
YunoHost 3.8.5.9 (stable)

@hermann-san sorry for the late answer. I am not able to reproduce your issue, though. :confused:


  • Testing branch status as of 2020-10-25, PR 153:
    • :arrow_heading_up: Flarum has been upgraded to beta.14. Changelog
    • SSOwat extension has also been upgraded to fit with the last breaking changes they made.

If no issue arises, merging in three days.

Note for later: investigate implementing some of the easiness-of-use introduced by the basic authentication extensioni.e. automatic login if user is SSOed, less clicks!

3 Likes

Bonjour.

Flarum est une application listée parmi les “applications fonctionnelles” avec une mention “faible qualité” dans la liste des applications yunohost.

Cela veut-il dire qu’il faut s’attendre à des problèmes si on l’installe ?

En : flarum is said by yunohost application list a “low quality” application, and a only “fonctionnal aplication”. Does it mean Flarum on yunohost could generate problems ?

Hello! Thanks for the ping, I had indeed forgotten to update the app.
You are right about being cautious after seeing the “low quality” warning. This can cover a wide range of issues.
Currently it is only the package linter not liking having -beta in the version name, so not much of an issue. The fixes are in the testing branch, but had yet to be integrated in production in the master one.

Let me run a final test and I will make the fix available to all. The quality level will go up again afterwards. :wink:
I will edit this post when it is done. :arrow_right: Done!

2 Likes

“Bravo” “Super” “Merci” “Gloire à t”
Thank a lot.

1 Like

Bonjour Antoine,
I’m running the latest flarum package in my production instance and works flawlessly.
A great pleasure to use and well designed software
@tituspijean thanks to make that software available to us !

1 Like

Testing branch status as of 2021-05-01, PR 165:

Feedback is most welcome.

To test on a new install:
yunohost app install https://github.com/YunoHost-Apps/flarum_ynh/tree/testing --force
, or to upgrade:
yunohost app upgrade flarum -u https://github.com/YunoHost-Apps/flarum_ynh/tree/testing

2 Likes

Thank you very much for the update. I had tried to install flarum before and could not properly access the admin panel. Now I tried and it works fine, I was even testing an extension and there is no problem.

Regards!

1 Like

The upgrade went well (I had just this warning: Warning: lsblk: /dev/loop6: not a block device) and everything looks ok. And above all, I can now access the admin panel without any problem! :tada:

Thanks a lot!

1 Like

aaaand I forgot the main reason I dropped the SSOwat extension was the bug with the admin panel. :sweat_smile:

Thank you both for your feedback! I will release this version in 3 days if no issues arise.

2 Likes

No problem, thanks a lot! :blush:

This one arises while adding a swap file. The helper lists the available and compatible storages and this kind of warning can come up. I will check if we can silence it.

1 Like