[fixed] Newly installed application aren't accessible by a specific (yet allowed) user


I already asked Aleks but maybe someone will have already met my… strange problem.

I just installed Dolibarr with the Community app on my 2.7.4 instance and it’s running smoothly for everyone, except for my own user account, which is yet explicitely allowed

Does anybody know what could be the reason, or maybe where should I look for some clues to solve this by myself ?

I know I’m not giving a lot of context but I actually realy don’t know what information could be relevant to give, so just tell me what you’d need.

Thousands of thanks to all the Yunohost community, you’re soooo great !

Can you explain more details about the problem? What is happening and what is expected ?


The app is not displayed on the dashboard when I’m connected with my own account, but it is displaying and working when connected on other accounts.

When I try to connect via the appropriate url, I’m redirected on the dashboard instead, as if I wasn’t allowed to access it. Yet I tried to explicitly allow my user to the permitted ones but it’s apparently not enough.

I don’t understand what kind of configuration file or else could be responsible for that. Could it be the SSO ?


yunohost app clearaccess app_name

Thx but didn’t work… BTW, I tried to reinstall the app last week but it didn’t fix it. I guess there’s something wrong with my user… I wonder what could have I done wrong to break this. Strange thing is that every other apps work very well. Only Dolibarr’s making me this.

Dolibarr app app is unstable as mentioned in the readme. I remember when I tried it long time back it installed some apache stuff which broke the server. Now it looks to be nginx compatible but still has some issues.

Your problem maybe completely related to the Dollibarr app or it can be some problem in sso config files.
Can you show /etc/ssowat/conf.json and /etc/ssowat/conf.json.persistent ?

1 Like

Oh ! Thanks, that was it ! I dunno why but my .persistent was uncomplete, Dolibarr missing.
Can you tell me how this file is generated and what’s its point ?

I don’t know the reason. You should ask the core developer.