[FIXED] Bug: Locale is Unable to Set


#1

When using ANY app at all, or even the panel, I get a UTF-8 issue. I’ve searched and tried everything, however, I’m getting this error everywhere that UTF-8 can’t be set.


#2

How does the error actually manifest itself ? Do you have a screenshot or something ?


#3

Everywhere. During logins, as warnings, during installations, when I’m booting the machine. On a fresh Debian 9 install with the the same ISO, no issues occur. I’ve re-installed Yuno 3 times, but this is causing many issues. For example, I can’t install gitlab-ce


#4

So that’s when you install from ISO ?

Basically that’s a very annoying warning, but that should not prevent anything to work anyway … if there’s an actual issue, that is not the corresponding error…

To fix the warnings, according to some thread, running ‘sudo apt install locales-all && sudo dpkg --configure -a’ might do the trick (but those locale issues are always quite mysterious to me)


#5

Not an actual ISO, I mean’t the origin of the OS is the same. I’ll give that a try.


#6

Well what image (or install script ?) are you using exactly …? What’s your hardware ? (I’m trying to understand better what’s the root cause and/or how we can fix this upstream so that it stops happening)


#7

The Install Script is for Gitlab-CE, however, it appears everywhere. My hardware is from a company, however, their servers usually work. That’s a snippet of the error VV

perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = “en_US.UTF-8”,
LC_CTYPE = “en_US.UTF-8”,
LANG = “en_US.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory


#8

So that’s a VPS ?

N.B. : it’s not about your server not working, it’s just Perl (some programing language running some programs) complaining about it’s inability to communicate in proper American English, so it just fall backs to the default language which is … English. (not American though, maybe)


#9

It is, however, it gets caught in a loop and never installs. It also affects other parts of the OS like SSH, when I log in the error appears.


#10

Just … what happens if you try to run this command …

sudo apt install locales-all && sudo dpkg --configure -a

#11

I ran that and it did the same thing


#12

What does locale -a returns ?


#13

Every single locale including en_US.utf8 but not en_US.UTF-8


#14

Naively I’d say this probably isn’t the problem but let’s make sure of this …

Can you run :

sudo locale-gen en_US.UTF-8
sudo dpkg-reconfigure locales

(maybe re-log after this)


Locales en français sur Raspberry
#15

After many restarts it seems to have fixed itself, ran those commands for good measure but it somehow resolved… I don’t know what the official fix is, but this worked…


#16

Note: gitlab still won’t install