Fix 502 Bad Gateway error on subdomain

My YunoHost server

Hardware: Raspberry Pi 3
YunoHost version: 11.0.10.2
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

I have installed send to my domain but I am getting a 503 bad gateway error when attempting to access it from the web. Everything in the admin console looks right and I just did a normal installation from the app catalog. This is actually happening with more than one of my applications which are installed to subdomains of my primary domain, which functions fine. diagnostic tool says all of my DNS stuff is correct.

check if send service is running on services
check if all the required ports by yunohost are open on your router
try to update yunohost dyndns by the command:
yunohost dyndns update
503 is a blocked reply or segmented in many cases
try to reinstall it and make sure all things above again

I don’t know how to do this. I tried sudo yunohost service status and they are all running.

I have configured them according to the documentation and every other service is working fine.

Received Error: No domain registered with DynDNS.

I fully wiped everything and did a fresh install, problem persists.

I’ll note that the service works perfectly fine from my primary domain. It’s the secondary domains where I’m hosting specific apps that are the issue.

503 bad gateway means there is a drop in the middle mostly, sometimes if the origin server cant reply or achieve the target,

so the symptoms is indicate 3 things in general

  1. problem with the server itself,
  2. problem with the firewall or closed port,
  3. problem with the DNS referrals

you can simply check if “send” service is running by the command by the command:
yunohost service status send
image

or by simply go to your admin panel

you’re declarations about two things is not clear,
once you got " No domain registered with DynDNS ."
that is indicate you don’t host your domain with yunohost dns’s?

are you using your own domain? something you got from another service than yunohost dyndns?

if so how youre updating your domains?
you should have another dynamic dns client running on your server, you need to check if that dynamic dns is running normally and updating all your name records fully,

and what do you mean by secondary domain?
do you mean subdomain or secondary domain?

subdomain its an alias for the main domain,

do a deeper test to your router,
go to your router interface → port forwarding, and open all ports from 22 to
20000 in a range, just one line, in most of routers you will be able to insert a port range instead of one by one,

there are situations the router has an open port but its drops the traffic for some reasons, cause the router itself has its own firewall,
so the only way to do it is to open that whole range and disable your router’s firewall for testing purposes,

i don’t know what router do you have but its should be simple,

after you will open a port range stop your router’s firewall you will be able to test if there are any drops on your server again,

chrome_sIDYal3EZS

I tried sudo yunohost service status and “send” does not appear in the list, nor is it in the Services page from the webadmin.

Using a domain I purchased through Namecheap. The Diagnostic tool says all of my DNS records are set up correctly.

This appears to have had no effect.

Here’s the log from the latest install attempt, which froze half way through and I had to unplug the Raspberry Pi to get the server back up: https://paste.yunohost.org/raw/kifirigudo

" I tried sudo yunohost service status and “send” does not appear in the list, nor is it in the Services page from the webadmin."

send is installed and no service name “send”, well thats something only aleks can help with,
i do have send service on my server,

i noticed something strange in your log, to the best of my understanding its looks like port 8095 trying to be in use for send?!
i have send installed and i dont have any requirement for port 8095, its not even on the firewall list on my server,

because you did involved an external dynamic dns server there is a possibility namecheap dns servers drops some traffic,

i don’t know if aleks have a better idea but if you’re asking me, you should test your server with an reliable DNS provider,
if you want to do so for completely free, please just follow my reply on this thread:

or the other option is: just get a domain from yunohost at least you will own it for testing purposes and second domain will anyway give you an second option to reach your server,

the reason i still think you should try with another domain, it is not because “send” its because earlier you mentioned you have the same problem with other subdomain apps as well sometimes,

and don’t forget to close back your ports on your router after you done testing, such open range is very vulnerable