Firefly-iii Error: User has no administration ID / Error

(Firefly-iii) User has no administration ID / Error 553 5.7.1

My YunoHost server

Hardware: VPS bought online - mythic-beasts
YunoHost version: 11.1.22
I have access to my server : Through SSH, through the webadmin, direct access via keyboard/screen (VNC) into debian
Are you in a special context or did you perform some particular tweaking on your YunoHost instance?: yes
If yes, please explain: I changed the domain to an external domain, but I ran diagnostics and everything is perfect.
If your request is related to an app, specify its name and version: firefly-iii 6.0.5

Description of my issue

To get help efficiently, please explain what you are trying to achieve, in which context, what you tried and provide detailed error messages and logs if you can.

I’m currently trying to figure out what is broken in my firefly installation, I’m getting the errror:

Unfortunately, this error was not recoverable :(. Firefly III broke. The error is:
User has no administration ID.
This error occured in file /var/www/firefly-iii/app/User.php on line 315 with code 0.

Previously, the issue I was getting was this.

Unfortunately, this error was not recoverable :(. Firefly III broke. The error is:
Expected response code "250/251/252" but got code "553", with message "553 5.7.1 Sender address rejected: not logged in".
This error occured in file /var/www/firefly-iii/app/Jobs/MailError.php on line 103 with code 0.

I used nano to edit the .env file in /var/www/firefly-iii/, and changed the email to my own smtp email, and also changed the site owner to the same email.

# This should be your email address.
# If you use Docker or similar, you can set this variable from a file by using SITE_OWNER_FILE
SITE_OWNER="the email of my yunohost admin account"

I’ve tried changing my firefly’s email to one that doesn’t match the site owner (a gmail account), and the changing it back to the yunohost email.

When I send the test email, it goes through and shows up in my gmail inbox,

How to reproduce this error: I have encountered this error when making a new asset account, revenue accounts, anything in the accounts section

Error Logs:

hastebin - My Firefly Settings
hastebin - Error after I change the email to a correct email

I fixed it. I had to download on my yunohost phpmyadmin, go into users, add a user for myself, then go into user_groups, add myself, and then group_memberships and also add myself.

I went and made a 2nd account, and used the values from that as a guide on what to change. I hope this helps whoever has my problem in the future.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.