Firefly III Blank page installation error

Hi all - just started with yunohost - got fed up trying to work out docker compose files. Mostly going well so far. Having a little trouble with firefly, so would appreciate any help!

My YunoHost server

Hardware: VPS bought online - Digital Ocean Droplet
YunoHost version: 4.0.8
I have access to my server : Through SSH & through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I am having trouble installing Firefly III .

I have tried to install twice - both times seem to run succesfully & its listed in the dashboard as an available app. However i either reach a blank page or a ‘welcome to nginx page’

I have attached a link to the Nginx error & access log below.

There are a few others seeming to have the same problem- they have reported it in this announcement thread - [Firefly III] Manager for your personal finances

Try the updated version:

$ yunohost app install --debug

Warning: This branch is not tested with previous upgrades. Please keep a backup of old data before trying this.


Thanks for getting back

Tried that - getting an installation error - log below

Fault in installation script?

Have you installed php7.4 manually?

If yes, try to install the php7.4 dependencies and if there is an error.

php7.4-zip php7.4-mysql php7.4-xml php7.4-intl php7.4-mbstring php7.4-gd php7.4-curl php7.4-bcmath php7.4-opcache php7.4-ldap

If php7.4 is not needed by any app remove it and then try installing the app.

I ran updates including PHP 7.4 and re-ran the install script - now working as it should.

Thanks a lot!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.