Few struggles with the installation process of YunoHost

My YunoHost server

Hardware: Intel NUC, x86_64 Celeron, 8Gb of RAM, 500Gb HDD
YunoHost version:
I have access to my server : Through SSH, through the webadmin, and direct access via keyboard and screen.
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue


I have encountered a few struggles with the installation of YunoHost on my machine.

  1. UEFI boot doesn’t work. I’ve tried several USB keys that were used to boot other ISOs on this very machine, like Arch Linux and Alpine, but, regardless of the method I have used to create my bootable USB key, nothing have worked, and I have to deactivate UEFI boot in the settings to be able to boot it. To be even more specific, my computer doesn’t even list the USB key in the boot choices for UEFI; which doesn’t happen when using other OSs.

  2. The installation process struggles with HDD that already have an OS installed. The machine I’ve used was running a standard installation of Alpine Linux. I’ve just booted my USB key, ran the default option for installation, and, I’ve chose to use the whole disk for the installation of YunoHost. The installation got stuck in a loop there, because YunoHost was unable to repartition the drive. I had to shut down the installation of YunoHost, use another USB key with another OS, just to run sgdisk --zap-all /dev/sda in order to force the partition table to reset on my hard drive. And then only, YunoHost was able to install flawlessly.

Best regards.

1 Like
  1. Yunohost is not meant to be installed as dual boot, or on a computer with another operating system. This is to make self-hosting things easier for non-system admins.

Also, it seems you have no problem as you successfully installed Yunohost.

If you want to post this in the Discuss forum, you can discuss why you feel UEFI should work, or how dual-boot systems can be better handled in the installation script.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.