Failure to install

My YunoHost server

YunoHost version: 11.0.9
I have access to my server : Through SSH | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Trying to install with the simple graphical installer, and a USB flashed with the 64 bit installer. No extra or weird steps taken. Following the installer has not yet yielded a bootable system for me, after several attempts with different USB drives and various levels of drive formatting. This included installing Debian 12, which worked perfectly fine after the first install. I will describe the last few attempts to install Yunohost here.

Steps taken:

  • Use GParted Live on a USB to completely remove all partitions on the only drive present on the Beelink pc
  • Flash Yunohost onto a USB and boot into it in UEFI mode (the only option present in my BIOS)
  • Follow all graphical steps up until the Disk Partitioning step
  • Get a message stating

This machine’s firmware has started the installer in UEFI mode but it looks like there may be existing operation systems already installed using “BIOS compatibility mode”. If you continue to install Debian in UEFI mode, it might be difficult to reboot the machine into any BIOS-mode operating systems later.

If you wish to install in UEFI mode and don’t care about keeping the ability to boot one of the existing systems, you have the option to force that here. If you wish to keep the option to boot an existing operating system, you should choose NOT to force UEFI installation here.
Force UEFI Installation?

  • Select Yes, because I don’t care about keeping any previously installed system bootable (do note that there is no prior system installed, the drive has been wiped)
  • Select Guided - use entire disk
  • Select my disk /dev/nvme0m1 (the only other option is the installer USB)
  • It complains that “No EFI partition was found.” and asks if I’d like to go back to the previous step. Selecting Yes boots me back to the same prompt forever, so I select No so it continues the installation
  • The “Install the base system” and “Select and install software” steps start progressing for a while, seemingly installing packages
  • The next step varies between my first and second attempts to install:
  1. My first attempt resulted in a failure message for grub: “Executing grub-install /dev/nvme0n1 failed. This is a fatal error." The OS is not bootable
  2. I redid all the above steps with no change, and the second attempt had the installer seem to finish, or at least exit after installing grub, but the drive is still not bootable; no sign of grub as a boot option for my system
  • After 2., I can see using a live Ubuntu USB that the nvme0n1 seems to have all the partitions needed to boot, including an ext4 boot partition and a extended partition that includes a logical swap and ext4 data partition. However, there is still no option to boot into this OS from the bios, it just drops into the UEFI interactive shell when I turn the pc on with no USBs attached, and there are no entries in the boot menu.

Can anyone instruct me on what else I should try here?

As mentioned on the chatroom, if it worked with Debian 12, install instead a plain Debian 11 then run the install script (“Remote server” option from our documentation).

This seems to have gone well, and got me to the post installation in the browser. Thanks! Kinda stinks to see that the installer is broken, though.

What do you mean?

As I detailed in the original post, there was no way for me to get Yunohost installed using the .iso. I tried about 10 different variations of starting points and set up paths, including trying the advanced graphical installer, and couldn’t get it booting. Maybe it’s some crazy quirk with the PC I was using, I haven’t tested the iso installer on anything else.

If I recall correctly, we never actively trained ourselves to understand and fix UEFI on our ISOs. :frowning_face: The good thing is that it always works with the Debian ISO + curl script method.

1 Like

Ah, gotcha. I may scrub the docs to see if I missed anything about that, and maybe make a PR to note in the setup guide that it may not work in UEFI mode.

Yeah, the script worked perfectly and was quite fast! I may also put a reference to that in the Regular Computer install guide, since I didn’t think to check the remote computer section for a script like this.

I really like this project, and I think more people should use it. I haven’t found much else like it.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.